Macro not running

I want to simulate a “test fire” button on my k40 (running MiniGerbil, Lightburn 0.9.07) using the following g-code:
$32=0
S200
M3
G4 P200
M5
$32=1

I’ve created a macro and pasted the code above. Upon clicking on the button, the Lasers state goes to “Busy” and does not finish. I tried running the same lines from the “Command” input field by removing all newlines and that works.

Would you know, why the macro does not run/does not finish, if it’s ran via the button? I’m attaching a gif, which shows the issue.

Thank you.

The first and last lines shouldn’t be necessary, and the first would be $32=0 if you decide you need it. They aren’t GCode, so the streamer might not like those, but I’d be surprised if it doesn’t work with the correct command in the first spot.

Thank you, I’ll try it out tomorrow, without the $ setting lines. Sorry about the typo in the first line (the gif actually shows the commands, which were sent). I’ve taken the commands from the official MiniGerbil forum post, so I thought it should work, since others have already tried it.

Hmm - if this is for the Mini Gerbil those might be needed. Paul has done a few non-standard things with his version, so it’s possible that the M3 command uses velocity ramping, where standard GRBL reserves M4 for that, and M3 is constant power.

1 Like

It’s on our buglist to change the macro sender to go line-by-line. Currently it uses the streaming code, but for some things like the $ commands, they don’t buffer the same way on the GRBL side, so they have to be sent one line at a time.

1 Like

Is there a fix yet for this? Macro not working after update to 9.07.

Thank you, I will download and check.

It works perfectly for me now. Thank you, Oz!

Works great after re-downloading V9.07. Thanks!