Macro not working - a simple "test fire"

My issue is pretty much identical to Macro not running

i.e. I tried to enter the described macro to give me a Macro for a short laser fire but the Macro never completes. (I get exacly the same result as the gif in the above issue)

I am using LightBurn 1.0.06 and a K40 using Mini Gerbil v3 (firmware VER:1.1f.20211209 if that matters)

The above (2019) issue indicates that lightburn did not like the $32 lines so I tried the same Macro without these two codes $32=0 and $32=1, just to see if the Macro would finish - but again it sat in “Busy” until I pressed Stop.

Any ideas what I have failed to do correctly?

(I googled for any way to see on the console what comands it was transmitting to the laser - i.e. to see if it had transmitted the M5 correctly to turn the laser off - but could not see how to do this. Any hints on this or is this a pointless question)

The issue turned out to be the G4 P200 / G4 P250 command
instead of waiting 200 (or 250) milliseconds it was waiting 200 SECONDS.

The recommended fix to get me working was to use:
G4 P0.25
which did indeed make the Mini Gerbil V3 wait 250 milliseconds between the commands.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.