MAJOR Update 1.0 problem

So, I opened lightburn and downloaded the update
I only use my laser to laser engrave text etc into my wood cutting boards.
Well, now when I start a burn, all I get is one line across the bottom of my wood and the laser goes back and forth and doesn’t stop firing.
Please help

I do believe you need to switch on Laser mode in your settings. Find $31?? Can’t remember right off what it was.

(We addressed this over email, but I’ll summarize here)

$32=1 is the setting to use to enable laser mode. The summary of the issue is that Franklin had ‘Fast Whitespace’ enabled, but the speed set to 0, and had laser mode disabled.

The previous versions of LightBurn would ignore the ‘fast whitespace’ setting if you didn’t give it a speed. The new version treats 0 as “go as fast as allowed”, so it uses G0 moves to traverse through whitespace. If you don’t have the controller in Laser Mode ($32=1) it will not disable the laser when it changes from G1 to G0 mode.

So, the fix is any SINGLE one of these:

  • Turn off laser mode ($32=0 in the console, or use Edit > Machine settings)
  • Turn off the Fast Whitespace switch in the settings
  • Give the Fast Whitespace a speed to use

My recommendation is to leave laser mode enabled, as the overall performance and quality of the engraving should be better. With it off, the controller will pause constantly when the power changes, and the output will be darker where those pauses happen.

If you enable laser mode, and either turn off the fast whitespace switch, or give it a modest speed value to use (like 3000 mm/min) the overall engraving time will reduce, and quality will be at least as good as before, if not better.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.