Measurmement Settings are Wrong

Hello dear forum,
Im from Germany and I have a Atomstack A5 pro+ and Im using Lightburn on my macOS Sierra Version 10.12.6 and my English is not so good. My Problem is that my units of measurement are incorrect. My Atomstack has a maximum of 400mm on the Y axis and a maximum of 410mm on the X axis. This is my overall workspace. if I enter these values in Lightburn, the laser moves across the workspace, so I have to constantly convert while burning. If I want to burn something with a length of 1cm, I have to enter 3,197mm in Lightburn. So the values are never correct. What should I do?


Celal Ural

type $$ in console and copy/paste here the result

1 Like

Draw a Square start with 100 mm x 100mm then engrave it measure the actual size , go to Edit machine settings and then Calibrate Axis, enter the Requested (100mm) size selecting for each axis required and the Actual size of the result.
And Write, do this a couple of times, the larger the size you use the more accurate results you will achieve. starting small and increasing size of square until the results match.

1 Like

Here is my result:





































i don’t think 250.000 in $100 and $102 is correct. Act like @paulcw suggested you to make calibration of axis

This is almost certainly the cause of the problem. However, I thought that Atomstack did not allow GRBL changes to be saved so not sure how this would be resolved.

Try setting these to Atomstack defaults and see how it works. Enter into console:

1 Like

Thank you very much!

Thank you too! Before I did what @paulcw said, I did what berainlb said. And it helpt! Nut now I have a new problem. The Laser is very slow. I closed Lightburn and the atomstack. After 5min I opened it again and than on the console were:

Auf Verbindung warten…

Auf Verbindung warten…

Grbl 1.1h [’$’ for help]




Target buffer size found




Der Referenzierzyklus ist in Ihren Grbl-Einstellungen nicht aktiviert.

Stream wird gestartet

Layer C00

And there is a second Problem now. I can’t work on my workspace. Normally I made something for example a square and this square I want to begin at the end of my workspace (not by x and y 0). I did this by putting the square and move it to a place I want, but wherever I put it now, it always begin by x and y 0.

(Thank you all for your help, really!)

I believe your machine does not have limit switches correct?

If correct, then disable “Auto-home on startup” in Edit->Device Settings.

Not exactly following but here’s what I suggest.

  1. Make sure the laser head is at the front left of the frame when you turn on the laser. This position will be 0,0 since you don’t have limit switches (I’m assuming).
  2. Use Absolute Coords in the Start from: section of the Laser window.
  3. Retest

Absolute Coords is the most intuitive coordinates to use as the workspace matches your laser frame. However, it relies on the proper setting of 0,0 which is why it’s important to go through the startup process.

1 Like

Hello, thank you, for your Awnser!
My laser is very slow now… where should I begin to make it “normal” again / “fast again”.

Can you explain under what circumstances it is slow? It’s unclear what you’re experiencing.

I’m reviewing your GRBL configuration. These values look low for your machine. Based on other posts it appears the defaults are as follows:


This will affect speed and acceleration which could make your operate slower than expected.

1 Like

Thank you so much! And thanks too all others! This Forum and Community is so good!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.