Mill Right Mega V Rotary Circle not burning evenly

When burning circle the dimensions are correct but the speed slows down in the A direction (rotation ) and burns unevenly. If I burn a square all is normal. The rotary test makes one revolution. I have read many posts ,some with similar problems but have failed to find a solution.
Thanks for any help provided.

Mill Right CNC J TECH laser GRBL controller


A + X ?
Try lowering the X axis acceleration.

Thanks for your response parsec. The bottom circle is original Y acceleration of 1000
and 1/2 X at 500 instead of 1000. Top is original X and double Y. I don’t really know what the A+X? means. I don’t see any real difference.

You have setup your chuck on A axis.

Yes. you can see my rotary setup in the original post.

If you burn the circle flat is it ok?
I reread your post, could you put your circle in another layer (i.e… 26) and run the job.
Also could you check if the motor of the chuck is equal to X + Y axis.

dimensions are correct.

I am afraid I don’t understand what you mean here.

Sorry X + Y axis motors.

Good news! It works when I burn from layer 26 although I don’t understand why.
All the motors are the same size/type if that is what you mean.

I actually forgot to turn rotary slider button back on for the first try which worked on layer 26 so I turned it back on an tried both layer 26 and 00 . They now both work!
Does that make any since?

Something could have been set to C00 (most used by everyone), so I pointed to another layer (clean settings).

I tried again with rotary on and off. With it off the A axis does not move. The circle is small enough (.5in) that it makes almost no difference in the circle. But it does now work on both layer C00 (the original layer) and layer 26 . I guess its the mysterious world of OZ LOL. Thanks again for your help!


I increased the size of the circle to 1" . The cylinder is 1.76 Dia. It will still cut a complete circle but sill slows slows down on the parts of the circle which are facing to and away from the chuck thus burning theses area more. I switched from white tape to green which burns more easily. I think that is why the initial cuts where not complete circles. So…unfortunately I think I still have a problem with the speed of the A axis.

What Oz said:
" The issue is that the A axis is moving in degrees per minute, and the X axis is moving in mm/minute, and those are not the same unit.

If you combine a linear move with an angular one, the feed rate for the linear move takes precedence, so you have to calculate a feed rate for that linear move that makes the angular move complete in the correct amount of time".

Check if you have the latest MR firmware and read this topic with the solution.

It appears this is the grbl bug eventually described in the linked post and here in grblHAL at github. This github thread was hijacked off topic recently, so be aware that the bug is described and resolved in the thread through Feb 27, 2023, after that is off topic.

MillRight (MR) does not use grblHAL, but grblHAL is a descendant of 4 axis grbl v1.1i which MR does use, and I believe MR was a major contributor to 4 axis grbl V1.1i back in 2016-17 or so. Anyway, the bug is as described by @LightBurn Oz and @parsec , I refer to the bug as G94G1XAF bug; G93 (inverse time motion mode) does not exhibit the bug, but LB does not produce gcode in G93, just G94 (distance time mode). Nearly all other CAM sw has the option to use G93 mode and hence mask the bug. I collaborated with grblHAL developer on the fix since they had the bug also. I have the fix for the MR grbl, as does MR; applying the fix involves re-flashing the Arduino mega2560 board with the compiled firmware (sketch). I can send you the compiled fix and/or source code, and flashing instructions if you like, please send me a PM with your email address.


Thanks parsec.
I had read those posts before my post. A good bit of it over my head but I guess the jest of it is there may be a bug that requires new firmware. I had already contacted MR also before my post and talked to a person in tech support who I know has been there for a long time and he seemed to have no knowledge of the problem. I have also contacted the author of the mentioned post on the MR forum. Initially I didn’t think it was the firmware problem because I have lasered several rotary projects and didn’t notice the problem. It may have been that the type of projects I did just didn’t show the problem so clearly. Thanks again for your help. I will wait and see if I can get further information from Lou and MR.

1 Like

Lou sent me the hex file for the firmware fix. I installed it and it works great.
Thanks for everyone’s help.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.