Mini Gerbil connection issue with 1.0.00

Hi, I’ve been running version 9.2 because I couldn’t get 9.24 to connect, decided today to try to get it working with the new update and still having the same issue. Wondering if anyone is able to point me in the right direction. When I turn the k40 on lightburn says ready, but the console stays on “waiting for connection” it doesn’t home the laser and I can’t control it at all.
Thank you in advance!

I have the same issue, when I get this I quit Lightburn and open Putty (115200 baud) and send a “M30” command, this seems to get it unstuck. This happens with all versions of LB, not just 1.0.
I just installed a Mini Gerbil after my original Gerbil blew up. This never happened with the original

Do you have lightburn set at 115 baud too? I’m pretty sure it’s supposed to be at 230xxx. I also read setting up the laser you should choose grbl stm instead of just grbl, but I haven’t tried it yet because it works fine with 9.20

This is worth review:

https://awesome.tech/lightburn-and-mini-gerbil-tips/

There’s a Gerbl-STM profile in LightBurn that you should use. If you do that, the baud rate setting, S-parameter, and DTR enable flags are all set properly for you. If you choose generic “GRBL” as the device type, you have to know what to set those things to, or it won’t work properly.

  • DTR Enable should be on
  • Baud should be 230,400
  • S-Max should be 2048 (to match the default $30 setting in the controller)

I think that did it, the DTR line was not on. I’ll continue testing and report if the issue persists.