MKS DLC V2.0 connection issues

Hi team. Im needing a little help.

I have a MKS DLC v2.0 board. When trying to connect it with the PC it comes up with an error saying windows cannot find a driver and the device has malfunctioned.

I have tried uninstalling the driver and re installed it. Didnt work. Ive also got a Nano board that connects perfectly.

Ive tried switching out the USB etc as well as using a different PC.

Would if be safe to say the board is faulty?

TIA

Which kind of drivers have you installed?

You’ll need the CH340 drivers installed to talk to this board.

I don’t think Lightburn includes these drivers, but it might. One way you can install these is from the ‘Tools’ menu of LaserGRBL if you have that installed.

2 Likes

HI thanks for your help. I have the CH340 drivers installed. Just to confirm i tried installing it through Laser GRBL still with no connection.

Thanks for your help. I have the “CH341SER” driver and the CH34x drivers. Still no connection.

If you have Windows as o.s. in device manager are the com ports present?

Another thought, I have several GRBL boards around that are based on the arduino. All of those boards will talk to the computer using just USB power.

This one will not, and it takes 20-30 seconds for mine to respond to an $$. I know it’s basic, but you do have power to the board, right? Just trying to cover all the bases.

anyway also this is not normal, i have 3 of those boards on 3 different engravers and all 3 responds immediatly when connected with USB. If your do not act like this maybe there is some issue elsewere

No worries. My pc wasn’t all that great when I bought it several years ago, so now it’s a not so great plus several years old pc. It works for me.

Back to the OP, did we ever verify that he was attempting to connect to a powered up board?

1 Like

Hi.

Sorry for the late reply.

Yes ive got the board plugged in to a power supply. Ive got the power supply and USB connected to the board.

If I go into device manager it comes up with “device unknown” I’m away from my PC currently but will try to get a screen shot.

Is it flashed with firmware? If you bought a raw board it might need to have the firmware installed to it first.

if you get a “device unknown” in windows device manager you need to install drivers, you can install LaserGRBL and in “tools” you can find “install CH340 Driver” click on there and install

If you bought the board online can you post a link to where you bought that one from? I’d like to know more about it and which firmware might be flashed into its memory.

1 Like

you can find it here
without drivers and you can flash latest GBRL on it

So, Oz is right as usual… This board may have never had an original firmware flashed into it? I was hoping the OP could verify. :smiley:

well MKS release it with GRBL firmware and you can also find their firmware in Makerbase github

Hi everyone.

So… i got another board from the supplier this time its a V2.1. I plugged it in and bellissimo it connected right away.

However LB console has “waiting for connection” and it wouldnt connect to LB. After trying multiple times i managed to flash the firmware through xloader and now ive got everything to work.

Im yet to try a firmware update on the first board but i doubt its going to work and putting it down to a faulty board.

Seeing as I’m invested I’m going go try an air assist with a solenoid. I have no idea how this is going to work but Im sure google will have something.

i use air assist with this motherboard and a relay to command a pump, if you want some info… i’m here

That would be great and would like to take you up on that offer. Best way to contact you?

Here or with pm