My dimensions of my project is different then what is burnt

Hi, need a little help. I replaced my GRBL control board. My issue is the size of my project.

My Height and width do not match the burn, 2.5" x 4" actually burns about 6" x 10".

3018 universal laser GRBL 1.1e, 5W

I know it in the settings, but I am lost. Help


In Lightburn look at the Machine Settings option under the Edit menu. You should see the settings listed. Down around $130 you should see your settings but they will be in mm, not inches. Example, if you currently are seeing 2.5" in the X axis then you might see $130=63.5 which is ( 2.5 * 25.4 ). You will want to put the metric number for 6" in $130 and metric number for 10" in $131

Once that is done and saved, go back to your Device definition and see that you have also set the correct work area size there.

Thanks Doug, I may not have explained my problem correctly, I have a box the is 60mm x 85mm I want to burn, what I get during the burn is a box 140mm x 180mm.

You need to adjust the values ​​of $ 100, $ 101, $ 102 so that each axis moves correctly.


ok so then you need to adjust the steps-per-mm values mentioned being found in $100, $101, $102

1 Like

The proper solution would have been for you to have saved your previous configuration, so you can restore it to this controller. That stuff was all figured out for you… you didn’t happen to save that did you?

Save you current ‘non-working’ version somewhere also… you can make it worse.

Is the old controller alive enough to plug it in and recover the data?

I had 3 or so controllers with different burnt out parts, but I could still issue commands and use parts of the board, like a quick PWM generator… No need to replace it, just plugged into the usb and it connected. :slight_smile:

If you can do that, Lightburn will read the data from one (save it), then you can put the new one on and write back to it. This will be your ‘backup’ :crazy_face:


Thanks Jack, I was actually thinking the same thing. I am testing the old controller right now. Once I am sure it is good I will save it and use in the new one to see what happens.
Thank you both.

Should be an easy check… I’m pretty lazy, so I try to do less effort, the more the machine can do the better :slight_smile:

Good luck, let us know…

Take care :slight_smile:


Will let you know how it works out for me, thanks

Well I did like you said. When I connected the new controllers and started the working GRBL file, a few of the numbers change. I 1st tested the Frame and it was at least 3 times the size of the image. I changed all the codes to match the working file and the same thing, framed 3 times the size. Both have the same Grbl 1.1e [’$’ for help] when booted. The new one started with Grbl 0.9 I think it was.

Thanks for the help

You should be at least at grbl 1.0 or above. I’ve seen grbl 1.1f out there. Somewhere in there the $32 register came into being. Just caught that you are at 1.1e, that should be fine. Do you know how to read the controller configuration via Lightburn?

Could everything be 2.54 times the size? Is something set to inches?

The basic settings from your old board should work. I think it’s still not configured properly.


Yes, it is 1.1e, for some reason I could not get f to work when I installed and just went back to e and works fine with my old controller.
I did to ball park math, it is close to 2.54 times the size. I can run a burn tomorrow and get it close.
I agree I have something in the wrong spot for sure. I am going to try the vendor to see if they can help as well, China, dont know when i would get an answer

I’m guessing that lightburn is set to mm and the machine to inches. Check $13… Sets position feedback units from mm to inches. $13=1 for inches or $13=0 for mm.

Later, hitting the sack…


1 Like

Hope you had a good nap, I have everything set to mm. using the same GRBL for both controllers

I’m trying to think where else to look. I’m pretty confident it’s a configuration issue.

I hope you have set up to do backups of the configuration as they change…? On my machine I usually store them in a YYMMDD-name type convention. Only because it will sort by name by date. I usually have my working directories view sorting on the date field. But it works both ways…

Did you compare any of the step fields between the two machine configurations?

The original board should be configured properly, with the exception of $32 the laser enable.


Thanks Jack. I just figured it out. The board, what I am being told is not Windows 10 Capable. Great.

And it did not come loaded with 1.1f, was .9 something

RATTMMOTOR USB CNC Controller 3 Axis 1.1f GRBL Controller Board CNC Router Machine Control Card with CNC offline Controller CNC Router Offline Control Module for CNC Engraving Miiling Machine from Amazon.

Thanks for your help. Will be looking for a new one, I need on with 2 Ys

That’s odd, develop a product that won’t run on 90% or more home computers??? I find that difficult to believe.

If you post the link, it’s better. I call bs on not compliant with Windows 8 or 10. It’s that no one will update the supplied software, so they don’t care. I believe it’s a CYA move.

Simply, you got ripped off, IMHO

Is what’s running on my grbl CNC3018 and I run it with Lightburn. It was $35. :slight_smile:

If you updated the firmware I’d bet it will work. Need faith in these times :slight_smile:

If you’re willing, we’ll help the best we can :crazy_face:

Don’t know what you mean here. CNC machines have in general use by hobbyist x, y and z axes.


it is GRBL and communicates over USB so it might be a pain to deal with Windows drivers but I doubt it won’t run on Windows. What I saw on Amazon even listed XP/7/8/10 versions were supported.

I think it’s a cya, didn’t want to deal with customers. Why did you buy that one anyway?

The basic hardware of those machines has been around a while and stable. It’s probably an arduino based animal anyway.

For $35 you can buy a woodpecker controller, like on mine and it works fine with Lightburn and the 3018.

I think you have working hardware, but a flaw in the configuration. That is the problem so many times.

Was this a typo?

Good luck :slight_smile:


hi, can you tell me the size of the power jack?