My k40 laser stops operating when using move commands

I am new to the laser engraver/cutter arena and am currently struggling with getting my upgraded k40 laser to operate with LightBurn software. Currently I am unable to move any of the axis after one or two initial movements. It seems to not be sending any commands to the controller. I also have attempted to run a focus test and the laser will home to the upper left where my end stops are ( min x, max y) and then proceed to where it should start the operation. I see a quick fire of the laser and then no more movement. When I look at the laser screen, it shows busy and continues to clock but the unit is not moving and laser is not fired. If I attempt to hit start again I get an error stating that the unit is busy or paused. I can free it up by right clicking on device which will home the laser to the default upper right position. I then attempt again and get same results. I have tried to reinstall the laser both by automatic and manual with no changes.

I can run the unit with the jog controls without issue through pronterface, but for whatever reason LightBurn locks up after one or two movements until I reset it.

I have upgraded to a smoothieboard v1.1 x5 with a reprap glcd.
I have installed the latest CNC firmware that is listed on smoothiewares site
The config is based off of the recommended laser config off Dave’s laser

I will be attempting to run a simple Gocode through pronterface to see if it will run that way.

Any ideas as to why the unit locks up will be GREATLY appreciated as I do like the software and would like to be able to use this as my default laser program.

I assume it detected the device as Smoothieware?

@raykholo - Do you know if we need CNC firmware or a Laser build?

Yes it did. It actually detected two smoothieware controller (both with the correct size that I had set in config) but plugged into only one board via usb with no other devices plugged into the laptop

Does it lock up if you just run a simple square?

If so, it’s not a streaming issue, because a square (not filled) should be able to send to the laser without exceeding the buffer size.

I have heard of some GLCDs causing lock up. Have you tried without it?

I will give that a try. Haven’t tried to send simple code through the program yet due to the general move function becoming inoperable after about 3 commands to move. I will try without the glcd as well .

If the board isn’t grounded properly, or you have a ground loop, or communication interference, or a crappy USB cable, or a cable that’s way too long (> 15 ft), any of these can cause comm problems. You haven’t said yet if this has ever worked correctly, or works with other software, so it would be good to try something else, or even a serial terminal, to see if the board locks up just by sending commands to it from anything or if it’s specific to LightBurn.

the firmware_cnc is the current and proper build type for lasers(renamed to firmware.bin of course). its what i used on my smoothieboard and what I believe the upgraded firmware you coded for clustering is based upon.
You said you just upgraded to the smoothieboard, correct? Pictures of your wiring setup, power supplies, USB/computer connection, limit switches, etc would help us diagnose your problems. :slight_smile:

I will attach some pics of what I have set up, and yes, this is my initial start with this unit and laser cutters in total. I am using a newer laptop with windows 10, a very short usb cable along with a number if upgraded items for the unit.

I haven’t had this operate properly at all as of yet due to firing it up just yesterday. I am still trying to figure out how to run a simple code through pronterface to see if it locks up there as well.

I did remove the glcd and had the same results, as well as running a simple square. It will run the square but as soon as it returns to the 0,0 origin it locks up reporting 99% and busy.

If I try to move the unit at all in the move tab I get nothing, but the laser tab reports busy at 96%.

The unit will home upon connection to the upper left where the end stops are correctly. Once this is completed, I get only one quick movement from the laser, either x or y before it won’t run any longer. When I try to use console I no longer get any return from it as well after entering any code.

Unfortunately as a new user I can only post one pic so here it is :flushed:

I have installed a dedicated 10A 24vdc power supply to run the steppers, 5vdc to the board and the 12vdc led lights. I am using buck converters to step down the voltage to the smoothieboard and lights and running the laser on its factory power supply. I designed an interface board to add in safety switched for the doors, water flows with and temperature sensors, along with a relay interface for any 110vac item I am running ( fan, pump, laser ps and air compressor) I also have tried to keep any of the low voltage items away from the 110vac to help eliminate any potential induced noise.

Currently I am capable of sending commands uninterrupted from pronterface and experience no signs of loss of communication or lockup. I am working on getting something I can run from it to see if I have similarities issues.

Restriction lifted.


If you would like to see anything in particular closer, let me know and I’ll get my camera down on it. I have added the z axis table but am not using it in any code as of yet.

Your problem aside, what a nice clean build. You did a great job on modding it.

Thank you very much. I’ve been slowly getting things together over the past two weeks, the worst of it waiting on a smoothieboard… there are a couple things I’ll return on to clean up once I get it in the final stage and working. It’s been a lot of fun to this point, now I just need to get it to play nice. :grin:

Right on dude, thats what I call a proper response :slight_smile: Nice setup btw, i like the control panel layout you have. Does that LCd decimal move over? better resolution as its only up to 5v for power scale to get .01 over .1v, its what i use on mine and it works well(diff lcd readout a cheap mini one). Did you add the regulator on the board for the GLCD interface? i know it can be on the interface board or right behind the main power connection and some didnt have it preinstalled. (just going over the smoothieboard known fixes)

That blue USB cable, throw it away. Those are known for such varied and unreliable qualities that it causes most problems. Get a good shielded cable with ferrite beads on the end. It really does make a huge difference in noise getting into the line. Maybe check all motor connections again for solid seating in the sockets, firm seating of the pwm line, and no pinched wires. I don’t think that’s your problem as your wiring layout is on point and well thought out(even if at first glance it looks crazy lol) Id say start there and mayber well get lucky.

oh and im guessing that motor in the electronics bay controls the z bed?

Yes sir, that would be the z axis stepper and agreed, my ocd is not sitting well with how the wiring appears at this time, I will be cleaning it up once I have it up and running fully.

I will definitely throw away that usb cable. Not much thought about it until you mentioned it and the possibility of noise across it. I have not added the regulator on board as I am using the external but a: willing to give it a shot if you think it could be an issue. As far as the readout, it’s a 100ma unit so the decimal is stationary. I am sticking with about 3ma for my testing since I’m using tape on the bed for my work. I’m almost afraid to crank it up much more. :joy::joy: when I was aligning my optics I hit that current pot and lit it up real quick… burned the tape in record time… it’ll be interesting once I get to actual cutting of stuff…

Just an FYI, I am able to run a simple gcode rectangle through pronterface with no lockup. Laser control is responding as necessary and the unit is completing the rectangle correctly. I can run the code multiple times without any noticeable problems. I will get a better usb cable and try again with it and let you know.

Thank you for all the help here as I really hope to be able to use your software. And thank you for the compliment as well.

Just an FYI… I am able to run some more complex gcode by using the sd card on the smoothieboard. I was premature in my assessment of the working code in pronterface. It does the same thing after a bit longer. I will get a higher quality usb cable and look into my laptop to see if it’s shutting down the USB port comm for some reason.

Thank you again for all the help. It’ll be late this week before I’m back on it so I won’t have any additional info until the.

Have a great week!

for the laptop shutting the connection down that would be power options in windows. I would turn off all ability for the pc to disable usb connections. Here is how to turn it off
Go to Start menu-Settings-system. under power and sleep click on additional power settings on the right. then click on change plan settings for your current active plan, then on change advanced power settings.

Heres the menu you want. To to the USB section and disable the usb select suspend setting. Click apply. that shuld stop the computer from turning off the port randomly. While your there I would also change sleep options to never so that wont happen also.

and for the pot setting i just set mine to be at 15ma using the test button, and thats my max. then adjust my speed/power in LB as needed for various materials and save in the library when i find settings that work. makes it easy to setup from one project to the next.

For the connection shutting off, we have a FAQ with links:

1 Like