my K40 no longer reacts to the lightburn command

my K40 no longer reacts to the lightburn command after installing the 0.9.22 update, the motors are powered on so the connection goes between lightburn and minigerbil, but no command works, move, house, trip, nothing works. Anyone have a solution to help me out? Thank you

1 Like

Can you check in Edit → Device Settings and tell me if the ‘Enable DTR Signal’ toggle is enabled or not? If it isn’t, try enabling, then restart the software and tell me if that helps.

image

OK thanks now it works except i have another problem "Two g-code commands which both require the use of XYZ axis words were detected in the block.
Online or almost online 36:
Interrupted work "

Can you tell me from this come?
Thank you for your quick response. You are pro

That is usually a communication error caused by a poor connection to the controller, electrical interference, or something similar. Please load your project in LightBurn, click the ‘Save GCode’ button in the Laser window (below the Start button), save the file as .txt, and attach it to a post here so I can have a look. If the GCode output is correct then it will be electrical, grounding, or similar.

Thank you for the file that I use and in perfect condition, I use it several times.

BIPLANE ESSAI.TXT (85.6 KB)

Can you tell me which type of controller you are using?

I do believe that this some kind of electrical interference in the USB cord, or possibly a bad grounding issue - there is nothing wrong with the GCode itself, verified by an online gcode simulator:
image

Carte minigerbil. I removed all the electric source which was next to the K40, I added earth connections on the K40 structure and also connect directly to the laser power supply. I also add an earth connection on the fixing of the minigerbil card. I have tried several usb cables. I do not know what to do.

Is your air compressor on the same power lines as your laser? Try running without that on.

The air compressor is in the workshop one floor below it is not connected to the same phase at the electric meter, there is just the rubber hose which arrives on a valve filter next to the K40, I will try to remove it from the side of the K40, but I don’t think it comes from that, because everything is insulated (rubber pipe and fixing on wood). I will keep you posted as soon as I have tested. Thank you very much for taking the time to try and help me out. I wonder if it would not come from the minigerbil card because I have a lot of connection problem from the start, while with the original card no problem.

Here is a decent write up on grounding your K-40:

https://awesome.tech/k40-laser-grounding-instructions/

Merci je vais tout repasser étape par étape. Merci je vous tien courant.

Thank you, I will go through everything step by step. Thank you, I will keep you posted.

Have you configured your device using the Gerbil profile in LightBurn? It looks like you are just using “GRBL”, not the Gerbil specific profile, as that one should automatically set the DTR signal properly for you, and it includes a couple of other changes as well.

I just tried minigerbil, it didn’t change anything. Tomorrow I completely dismantle the k40 to check the complete earthing. Thank you again.

Hello everything is back to normal, I saw all my grounding and made a box for the card to be isolated from the K40 and everything works perfectly. Thank you very much for taking the time to help me out and excuse me, I’m a novice. Congratulations on your professionalism.

2 Likes

For a “novice” you did well explaining, communicating and made good judgement in working on/with your machine. Well done @fredo as this is no very common.

Thank you for your message.

4 posts were split to a new topic: Move commands not working with Ruida