My laser don't recognize work area

Hi I recently get my ortur laser and can’t get it set up right I was looking videos but couldn’t find what I need, my laser is not centered right its hitting the rails its like he don’t recognize the amount of distance that needs to move I set the origin to the middle of the grit and the laser move to one corner, it go home perfect its homing perfect, same whit the locations tool I move the laser where I wanted but it move somewhere else no to where I want and I’m getting frustrated lol …

Are you using Absolute Coords in the Start From pulldown in Laser Window? If not, switch to Absolute Coords. It will be much more intuitive to understand.

Yes I try that too… even delet my laser from the software and added again, and what happen whit that is when I try to frame the job is not framing near close the job or go and hit a rail… and set to 400mm to 400mm which is the factory set up I’m just turn on the option to fire the laser for framing

Can you describe the exact circumstances for what you’re doing when the crash occurs?

Also, please do a homing operation and then run these Console commands immediately afterward. Please send output:

$I
$$
$#
?

Example right now im at home i send the laser to origin on the middle of the grit and move to one side and crash using location tool the same set to go to the middle and go and crash

Target buffer size found
Bunch of number ok
Grbl system Comand was not recognized or supported

Can you send screenshots of LightBurn for the setup before the crash?

Can you try again? You need to press enter after each command.

Send a screenshot if it doesn’t work.









what machine ?

i had the same experience, but you need to set the work area in the settings page

in your case the width and height settings should be 400(mm)

but after saving that setting, you will need to completely close and re-start lightburn for this to write to the grbl initiation file i believe (that bit took me a long while to finally grok), and to reboot the laser - that is, save the file, close lightburn and reboot the laser before reconnecting

it’s because that setting will not “take” until you reboot the laser, as it has to write to the initiation file

consider it’s like changing the bios on a computer, only in this instance you are saving the file in the settings window, but it requires a reboot to establish the new settings

thereafter your only issue will be to define the origin, which for me was bottom left, although home is top left

your machine will have a defined origin

i too was completely sick of the bang! limit and horrible noise until my wife said “have you tried turning it off and turning it on again?” and of course, it was the moment of epiphany once it actually held the settings

i think this will cure your issue - it certainly fixed mine

the software is excellent once you get past this sticking point that is poorly documented but probably a major problem for all very new users

hope that helps !

Is set to 400mm but then when I go to work ares settings says 17.5in wich is the conversion. I even deleted lightburn from my computer and tried again and still doing the same I’m gonna try again and let you know thanks men

Actually, nothing in the Device Setting screen will write anything to GRBL. However, there might have been something else going on that was cleared up with a restart.

@Carlos787 It was hard to work through those screenshots. It would have been preferable for you to cut and paste the content into a reply but I think I got what I needed from it.

The reason you’re having a problem is you have an offset set for some reason. Try this:

Type this one at a time into Console:

G59.6 X0 Y0
G92 X0 Y0

Power cycle the laser.

Work exclusively in Absolute Coords until you’re very familiar with the operation of your laser.

Let us know how this goes.

That’s a bit harsh … LightBurn has lots of videos demonstrating features, and (I find the documentation quite comprehensive - and if not the forum here often answers within minutes)

your mileage however, may vary.

1 Like

once you have the table size agreeable, everything else is awesome

i think you missed the point of that comment

the initial table size set up is neither intuitive, or well described, and my google-fu is very well enabled

i can guarantee that around a week of trying to use the settings to get the device to comply met with exactly the same results as carlos describes - i did eventually input some co-ordinates via the command line, but i am still ignorant as to whether that resolved the issue, or the reboot of the system components after resetting the initial set up on a re-install

again, the instructions to establish initial success are neither obvious, nor easy to find even with considerable search engine experience

I didn’t really find this to be the case. It’s one of the 5 choices you’re asked to make during device creation, name of your device being one. And thought it was adequately described.

To me the Origin question is by far the most troublesome and the implications more unintuitive.

How are you entering the commands? Please don’t just enter random numbers and syntax. Syntax is important.

Can you copy and paste from my post into Console and try again?

I copy and past them and still the same unsupported code

im using my laptop to chat whit you and phone for pictures