My laser had a hiccup, sort of

I may have fixed this issue on my computer. After double and triple checking all my wiring connections and I have not heard back from Ortur so I just went ahead and updated the firmware. My laser framed fine and burned three different files.

I realized I was still on version 0.9.21 because of the install thing with the Com Surrogate when trying to upgrade to 0.9.24. I upgraded it with the COM Surrogate message and just click on ignore when that came up.

So, it was either running an older version of LightBurn (I won’t do that again) or the firmware v137 wasn’t playing nice.

Thank you everyone who chipped in with ideas.

Glad you got it working Ernie.



I have the exact same problem with mine did you fix yours

Yes I got mine fixed. One of the errors I got probably won’t apply to anyone else. I got a movement error which was from putting my laser on top of a chest freezer. It’s mounted to a piece of plywood but I didn’t realize the freezer top was crowned and it made the whole thing wobble enough to throw that error.

I updated my firmware and the problem went away. You might want to try that but you do have to use a windows computer. If you have the Laser Master 2 here’s the link to the Ortur site: Ortur Laser Master 2 – Ortur

Be sure to read through the PDF before you start. Hope this helps you get back up and running.


There is a way to update the firmware with Linux or Mac, it just requires mktools utility because of the silly way the MS-VFAT filesystems stores 2 directory names. ping me and I’ll look for the step-by-step I have used on my Linux system.

Hey Doug,

I have windows systems and the one video I found said you had to use windows. Your reply will hopefully help those who do use Macs.

1 Like

Yes, they do state it only works with Windows but that’s just because they are lazy and don’t want to support other systems. I’ve repaired a number of bricked controller boards since I’ve done STM32 development and I’ve been able to flash the bootloader. I don’t have Windows but did find an old Windows98 CDROM and booted a virtual machine and that’s how I validated what was going on. The bootloader looks for the filename in the hidden 2nd VFAT directory structure and the mtools package(available for Linux and Mac) contains mcopy which copies the firmware file and puts the name in both VFAT directory entries.

Learn to decode these error messages. We’ll try and help you do that… The problem is around (or at) line 52. If you post code look around these line numbers to find the offending code and NUMBER the lines to assist those helping you… :slight_smile:

The error itself is “9 G-code lock G-code commands are locked out during alarm or jog state.” It had an unrecoverable error. I’ve seen this when it did not home properly or some other positioning error. In Candle and other gcode senders that allow the ‘check’ option, to run the code without actually doing anything. If soft/hard limits are used this can help detect them. This sometimes turns up instructions that take the machine out of bounds. The controller can’t know ahead of time that an instruction will do that.

Does this apply? Factory response.


Thank you for the info. The decoding part is way above my paygrade. I had read somewhere during this search about the grounding but the poster never shared any real info. The link you posted was what I needed to get that done. Thank you.


Great, I’m glad it helped. I got the link from one of the users questions about that machine. LIghtburns people posted it. Credit due… :slight_smile: Sorry it took so long.

Take care

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.