My laser had a hiccup, sort of

I haven’t used my Laser Master 2 due to building an enclosure (as well as some life situations) for some time. I fired it up today and did a test with cardboard which worked OK. Threw in a piece of select pine and used the same text I created for the cardboard.

When I started the burn my laser made a sort of long beeping sound while burning the first letter and then shut down. I tried three times and got the same thing.

Here’s what I got in the console as far as a message:

Ortur Laser Master 2 Ready!
OLF 137.
Grbl 1.1f [’$’ for help]
[MSG:’$H’|’$X’ to unlock]
G-code locked out during alarm or jog state.
On or near line 52:
Job halted
Stream completed in 0:04

Where can I find a list of error messages and see what error 9 may be.

Thanks for any help.

FWIW, I’m going to be bringing my laser inside my enclosed porch. That way I don’t have to run out to my work shed while trying to get this fixed.

I’ll bet that a search for “g-code error messages” would get you there.

I did put that in the search box and nothing came up. I’ll try Google. I just posted in case someone had this issue and maybe would share some info.

Well, all I had to do was go to Google to get back here. Thanks raykholo for the link in another post I had to go to Google to find.

In case anyone else needs the link her it is: How to troubleshoot connection issues with USB

I was really hoping it was a simple fix. Same result, beeps while burning the first letter and shuts off. If anyone has any clues they care to share that would be great. I’ll be out in Google land trying to find a solution.

Assuming you don’t have a very long USB cable and that is the cause, have you tried moving the job within the bed of the machine to see if there is something going on with boundaries? Have you looked at the gcode and found line 52 to see what it is? Maybe post the code here for us to look at.

error 9 is a homing error it seems. here is a link to another thread on the subject.



I have not tried moving the job to a different part of the bed but will do that. My machine homes properly when I start it up and when I click on the home button. Are you talking about the gcode for the machine or the job? Thanks for your help.

The gcode for the job. You can copy it from the console window and paste here.

Here’s line 52 : G1X148.25Y137.42

I didn’t want to paste over 600 lines of code in here. If you need all of it can I paste or upload the file?

Maybe need to see 10 or so lines either side of that. Not sure if it will show anything though.
Have you tried a different job? maybe just a simple square to make sure nothing major is going on. It could just be this particular job.

I will try a different job later this morning. Here’s the extra lines of code:

; Layer C00
G1X148.25Y137.42 Line 52

I had to export the gcode. Do I have to be connected to my laser to get the gcode from the console (which would be a little faster)?

Tried a new file and get the same results. There is something I forgot to mention. My laser will frame both files like it’s supposed to if that helps.

Hmm different job does it too. I was going to ask if it is always line 52 in the error, but I assume not. Was the new job a very simple one? if yes, then it won’t be a memory error or such.
Is everything on the same layer?
Over travel isn’t set way too high or something silly?
I assume the preview is all ok and doesn’t show anything strange?
If you use an online previewer any issues there?
It’s starting to sound like an electricsl noise issue, but difficult to prove. Have you tried a different USB cable?

I did try an old printer cable and actually switched to my other laptop. It starts and burns about 10mm and quits. I then have to shut down the laser and restart. One single layer and preview is fine. I just created a 60mm x 60mm square. I’ve never did anything with over travel. I think I will open one of my files and see what it does. It will have to wait until later, have a few errands to run. Thanks.

I think I’ll just delete my laser from LightBurn and reinstall again and see what happens. I may try installing the latest firmware update from Ortur if you think that is an option to try now.

Always worth a try Ernie. I have run out of suggestions at the moment, but maybe one of the other members might be able to throw some light on it. Let us know how you get on.

you will find lots and lots of disconnection errors and many are either tied to Windows doing something or USB electrical issues. I don’t do Windows so as for USB:

  1. make sure your computer and laser are on the same electrical outlet to eliminate ground loops
  2. try a better USB cable, preferred are ones with noise filter chokes on each end
  3. try using a powered USB hub in between computer and laser.
  4. IIRC there are different versions of GRBL you can pick from when setting up your machine. My Ortur LM1 I use plain “GRBL” option.

David, Thank you for trying I appreciate you taking your time to help.

Doug, I’m going to get a better USB cable today. I’m running laptops on battery unless they are charging. I do have a powered USB hub but read somewhere to not use one. (Hold my beer :rofl:) so I’ll give that a try. Thanks for the suggestions.

Hi Ernie - while I don’t have an exact resolution to this issue, I wanted to share that I’ve encountered the same/similar issue. While I consider myself a newbie, I do have many hours of burning with LB and my Ortur LM 2 under my belt. I often burn multiple objects of the same type and design for my business so I’ve created a number of templates to maximize my use of the available space. The only time I encounter this issue is when I’m burning near the edge of the frame, certain designs will trigger the issue in those locations and others do not. So for my setup, I believe the issue to be mechanical in nature, something about the laser head being close to the allowable border causes it to jump (I’ve noticed this behavior of jumping and losing its location when framing objects that go right up to the border as well). I should mention that my templates are within the acceptable burn area and not touching the edge but are very close.

Wanted to share that in case it gives you another clue to help resolve or perhaps prevent, the issue from occurring.

Good luck,



Thank you for the info. I have a template for doing bottle opener boards that is kind of close to the edges and bottom of the ‘allowable’ burn area. I can’t wait to fire that one up and give it a try. I had my laser apart for adding some riser blocks and feet as well as belt tensioners and a Z axis adjustment. I also built an enclosure. I wanted to check my focus and thought I would just make some example text and see how it was working. I tried cardboard first without any issues with the text nowhere near the edges. I switched material, refocused and the wheels came off. I have put in a support ticket with Ortur and will see what they come up with.

I did get another error and it was different. Something about movement. Maybe my new Z axis adjustment add-on isn’t as stable as it should be. I’ll add that in here incase someone can see if this may hold a clue.

Project loaded in 0 milliseconds
Starting stream
Stream completed in 0:00
Starting stream
Stream completed in 0:00
Starting stream
Layer C00
Detect movement, terminate laser engraving!
Acceleration fluctuation:290
Reset Grbl.
Ortur Laser Master 2 Ready!
OLF 137.
Grbl 1.1f [’$’ for help]
[MSG:’$H’|’$X’ to unlock]
Stream completed in 0:22

Thanks for your reply Doc,