My Laser is not recognized by Lightburn V1.2.01

Hello,

my SculpFun S9 is not recognized by Lightburn V1.2.01.

my system:
Host: W520 Kernel: 5.15.0-47-generic x86_64 bits: 64
Desktop: Cinnamon 5.4.11 Distro: Linux Mint 21 Vanessa.
Machine:
Type: Laptop System: LENOVO ThinkPad W520

The USB driver and a camera are recognized by the system.
reinhard@W520:~ $ lsusb

Bus 001 Device 006: ID 090c:f37d Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) Endoscope camera
Bus 001 Device 004: ID 1a86:7523 QinHeng Electronics CH340 serial converter
Bus 001 Device 003: ID 17ef:100a Lenovo ThinkPad Mini Dock Plus Series 3

LB starts but in the console I read: “waiting for connection…”.

Now I have a valid license and the program should run under Linux.

reinhard@W520:~ $ /home/reinhard/.local/share/LightBurn/LightBurn
QMetaObject::connectSlotsByName: Connecting slot on_sbNumberOfPasses_valueChanged() with the first of the following compatible signals: (“valueChanged(int)”, “valueChanged(QString)”)
QMetaObject::connectSlotsByName: Connecting slot on_sbFrequency_valueChanged() with the first of the following compatible signals: (“valueChanged(double)”, “valueChanged(QString)”)
QMetaObject::connectSlotsByName: Connecting slot on_sbQPulseWidth_valueChanged() with the first of the following compatible signals: (“valueChanged(double)”, “valueChanged(QString)”)
QMetaObject::connectSlotsByName: No matching signal for on_sbInterval_valueChanged()
QMetaObject::connectSlotsByName: Connecting slot on_sbMaterialHeight_valueChanged() with the first of the following compatible signals: (“valueChanged(double)”, “valueChanged(QString)”)
QMetaObject::connectSlotsByName: Connecting slot on_sbSupportHeight_valueChanged() with the first of the following compatible signals: (“valueChanged(double)”, “valueChanged(QString)”)
QMetaObject::connectSlotsByName: No matching signal for on_actionEdit_Text_closed(int)
connected
"5M Camera : 5M Camera " “/dev/video0”
“Webcam: Webcam” “/dev/video2”
"5M Camera : 5M Camera " “/dev/video0”
“Webcam: Webcam” “/dev/video2”
Setting camera to “/dev/video2”
res: 320 x 240
res: 640 x 480
res: 1024 x 768
res: 1280 x 720
res: 1280 x 1024
res: 1920 x 1080
res: 2048 x 1536
default: -1 x -1
Setting res: 2048 x 1536
Port open succeeded
"5M Camera : 5M Camera " “/dev/video0”
“Webcam: Webcam” “/dev/video2”
Setting camera to “/dev/video2”
res: 320 x 240
res: 640 x 480
res: 1024 x 768
res: 1280 x 720
res: 1280 x 1024
res: 1920 x 1080
res: 2048 x 1536
default: -1 x -1
Setting res: 2048 x 1536
"5M Camera : 5M Camera " “/dev/video0”
“Webcam: Webcam” “/dev/video2”
Setting camera to “/dev/video2”
res: 320 x 240
res: 640 x 480
res: 1024 x 768
res: 1280 x 720
res: 1280 x 1024
res: 1920 x 1080
res: 2048 x 1536
default: -1 x -1
Setting res: 2048 x 1536

I can’t get the camera set up either. In the ‘camera control’ my camera is shown and I can select it. but a picture is not shown. When I press the ‘Track’ button, a clear picture of the camera is shown in the window that then opens and then also transferred to the workspace but in the ‘Camera Control’ box the picture remains black.

What can I do?

Did you follow the installation instructions to add your user to “dialout” and “tty” group?

Installation & Setup - LightBurn Software Documentation

Not sure about the camera thing but see if you can at least address the device issue.

Hallo berainlb,
of course!

Do you get a terminal device created in /dev?

If not, check this post out:

Thank you for the quick reply.
No, I have not created a device in /dev.
Where is that and how do I do that?
The post ’ Laser won’t connect in (X)ubuntu OS Specific’ I have followed.
In the file ‘85-brltty.rules’ I found an entry for the ID and commented it out. After that I did a ‘reload’ and rebooted the system.
No positive result. Everything is the same, unfortunately.

Now it works.
I’m so sorry. Haven’d changed the Port. Now there is an USB-Port and that works.
Many, many thanks!!