My longer ray5 5w laser stopped burning

I received and assembled my longer ray5 5 w machine a couple of days ago. It worked great and created a few projects easily. I tuned it off last night after completing a project and restarted it in the morning. I set it up for a simple burn with no changes to settings and it did not burn. The light flashes and it moves with the program but no heat leaving a mark on wood. The program works well, the machine follows instructions, it’s just not burning. Any help would be appreciated.

I would check the power connections on both ends of laser.

I appreciate the idea but I have no clue how to do that. I have unplugged and reconnected wire going into laser but all other parts are in side the casing.
Thank you for responding though.

Hey, that is almost exaxtly the same problem as i have with mine Ray 5 10w. It worked just fine and then it just stopped to burn. Everyting else works except the laser beam itself. Even the blue output LED indicates output…

Did you find a solution?