My MAC no longer sees my Laser


I was hoping someone could offer some advice.

I have been running my laser with an iMac, since I got the laser. I just switched internet provider, and had to return the hardware.

I was connected via Ethernet using the supplied router from the internet company.

I first tried connecting the Laser to the computer using the cable that I was using before and it didn’t work. So I searched here I came upon a couple of posts. One said it had to run through a switch.

So I went out bought a switch. No help. I tried changing the address from to on the laser and in Lightburn. Still nothing.

I have tried different cables (in case one of the shorter ones was a crossover. But again nothing.

Could anyone possibly offer and help or suggestions?

Thanks very much!

It might help if you describe what network equipment you have. Can you ping that address from your Mac? From any other device on your network? What does your dhcp configuration look like? I doubt it is a problem with the Mac but it sounds like an addressing problem without more detail.

Most likely the original equipment used one domain address (192.168.1.x) and your new one another (192.168.0.x).

Find out the address of your pc and that will tell you what domain your laser needs to be in.

Have you actually tried a crossover cable connected directly between the cutter and the Mac?

No, I don’t think I have one. The cutter is about 10’ away from the computer, so I have a regular cable now going into the switch, and then a long CAT 7 cable to the cutter.

Not to sound stupid, but I don’t know how to ping it. I don’t think it’s the computer or the laser, I think it’s a matter of an address or something. Unless I do still have to et a crossover cable.

This is what it says on my Mac, (although I am afraid to change stuff like this because I worry that all of a sudden nothing will work) but should this correspond to something on the Laser now?

Ok, now we need to see what address you have set for the Laser. Please show that as well.

Your Ethernet cable is not connected to the router, or the router doesn’t see you computer. Addresses that start with 169 are self assigned and are not assigned by the router.

Your wireless Wi-Fi adapter appears to be properly connected and have an address assigned by the router. Select the Wi-Fi adapter and show its IP address.

Here you go…

And if you meant this screen…Screen Shot 2020-03-02 at 2.45.49 PM

Nope, this is the exact screen I wanted to see. If you compare the addressing from your PC to that of the laser, you will see they are not on the same network. You need to make changes.

This post is worth review if you haven’t already.

Please ignore the amateur network sleuths.

You have Ethernet attached - it clearly says so in your info panel.
You also have a “self assigned ip address”, again as it says in the panel

That means you haven’t set an ip address and don’t have any dhcp server offering up an IP address to your computer or other devices.

You can do two things: give your computer an address inside the same network range as your laser (192.168.1.x) and change the gateway address on your laser to that of your router ; enable dhcp in the 192.168.1.x range on your router and change the gateway address on your laser to that of your router.

If you don’t know how to do those, this is a great learning opportunity.

This part is not necessary. Folks trying to be helpful. Let’s educate and encourage, OK? And thank you for your technical contribution. Always appreciate your knowledge. :slight_smile:

I read what you wrote, and I think I figured out where I made an assumption and in turn a mistake. When I got rid of the wired router, I change the Mac to wireless for the internet. After the direct connection via Ethernet didn’t work, I ran out and bought what I thought was a router, but I looked more closely and it’s’ an Ethernet switch.

So I have two questions. If I were to go out and get an actual router, would that fix the connection issue?

Or, as you mentioned about learning (and I totally agree) should I just keep this and futz with settings.

If I change them, will I lose the connections to all my other peripherals? They are all connected via USB.

Thanks very very much, and I owe you one.


Yes, that’s your problem - very few Ethernet switches outside big industrial 24 port or layer 3 Ethernet switches will offer dhcp.

Any router or wireless AP with Ethernet ports should offer dhcp. You will be able to wire Ethernet to your laser and run wireless to your laptop.

But… you have a functioning router - that’s how you’re accessing this forum, so why don’t you plug your laser into that?

If you have the usual sort of thing beloved by ISPs the world over, it will have a bunch of Ethernet ports on the back, as well.

Checking your wireless connection status should give us all the info we need.

So: connect your laser to your wireless router via Ethernet; connect your laptop to your router via wifi; check the network settings on the Mac in exactly the same manner you did before for Ethernet; enter the router IP address on your laser as the gateway address and an IP address in the same domain (make the first three octets the same - I.e. 192.168.1) but not conflicting with anything else - you can check in Terminal by issuing a ‘ping’ command to the address you’ve chosen - ‘ping{ for example - you want a non-response, that shows there’s nothing at that address.

If your router is at, as is the most common default, you should be able to ping the laser without making a change - gateway isn’t actually used within a single IP domain as you’re not going through a gateway to anywhere, but RuiDa insist on it.

If, for some reason, you can’t plug your laser into your router, all is still ok - you just need to manually assign an address to your Mac Ethernet adaptor.

In keeping with your existing laser setting, so you don’t need to change anything at that end: address mask and leave everything else blank.

Connect your Mac to Ethernet and ping the laser - 6ou should get a response.

Hi Bo-

Thanks for the info. I went into the Network Configuration box, changed it to configure manually, and changed the numbers as you mentioned in the last post. I didn’t ping anything, but when I told the laser to frame the open job, it worked. So I am going to try to cut something now.

As a side note, I couldn’t plug it back into the new router, as it’s on the second floor, and my office is on the first. Hence why I went to wireless for the internet.

One last question. Can you possibly explain to me, what the numbers that you gave me represent?

Thanks again, and all the best,


No he didn’t - the link provided includes both Mac and Windows instructions. Reading would be one of the hallmarks of actual sleuthing as well. :slight_smile:

‘The numbers’ are IP addresses. Like a street address or telephone number for your network.

Without getting too technical, there are two sets of numbers - local to your network and public (the address you are automatically and transparently given by your internet provider).

There are three ranges for local, private addresses: to to to

You can use any of them, but typically device manufacturers use 192.168.0.x or 192.168.1.x by default.

The addresses are like street.building.floor.apartment addresses.

Simply, and not confusing you with all the various ways this would not be the rule, all your devices need to be in the same apartment to talk to each other.

When you manually configured your ethernet adapter to be in the 192.168.1 subnet (or sub-network of the possible millions of network addresses), you put it in the same apartment as your laser and they found each other.

If you needed to talk to a device outside of your apartment (subnet), you would need a gateway address - analogous to your front door - to tell your devices which route to take to talk to some other subnet.

It’s both a very simple and very complex subject - the simple is, make sure everything is in the same subnet and you shouldn’t have a problem talking.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.