Need Help Reviving My 80W Laser - X and Y Axis Won't Move

Hello All,

I’m hoping someone can help me. I purchased a red and black 80W laser cutter about 3 years ago. I got it all set up with a compressor, water cooler, and extraction system. After testing it on some paper, everything seemed to be in order and working perfectly.

However, life got in the way, and I didn’t get a chance to use my laser cutter as much as I wanted. Now, when I finally have time to use it again, I’ve encountered a problem: the X and Y axis won’t move at all.

I have experience working with CNC machines for nearly 10 years, so I’m not completely new to this. However, this seems to be an electrical or wiring issue, and I’m feeling a bit lost. The information online is quite scattered and hasn’t been very helpful.

If anyone could spare some time to help me troubleshoot this issue, or point me in the direction of someone who could offer support, I would be incredibly grateful. Thank you in advance!

Not sure I can help, but I can ask a few questions that may help others to help you.

With the power off can you physically move it by hand?

When you turn it on does the display activate? Any error messages? Can you scroll through the menus? Can you change the speed setting on the controller?

Does the machine attempt to home to the right rear corner?




Hi Tim,

Thanks for replying I appreciate any help. When it’s off I can move it by hand but it doesn’t move that easily.
The display turns on but shows no error and I can move through the menu. I haven’t tried to change any setting via the control.
The machine doesn’t move at all on start-up.

What is the loose connector in the 3rd picture?

Have you tried doing anything with the 3 rocker switches? I believe those are an aftermarket addition as my machine doesn’t have those.

I’m babysitting my granddaughter right now and can’t get to my shop to look in my panel to compare. When I can I’ll go take a couple pics.

That is for the rotary that I have I believe but I have yet to even try and plug into the machine. I have tried swapping the connectors around but still no movement on X or Y. I can move the Z axis up and down using the buttons on the side but that’s it.

I have tried flipping the switch to see if they make any difference but other than turning the red laser light on and off I can’t see much difference.

No problem thank you again for the help, I just want to get it back to working so I can get some use out of it now haha.

I took a few pics inside my case. My wiring on the motor drivers and dip switch positions are different than yours. Mine was manufactured June 2021.

I don’t have a motorized Z on mine. Don’t know if these will be helpful or not, but here they are anyway. I do know that the top one is X and bottom Y. Hopefully someone with more experience in the mechanics of these will be along.

Thanks for that Tim,
I’ll try a few things using your pictures as refference and see if I can come up with any resuts. Hopefully a laser wizard will come and help me further haha.

The Ruida is failing to boot. The X, Y and Z axes all have default numbers, that occurs when it fails to boot on power up.

Is this with your rotary?

Did you disable the boot sequence?

The ULimit- is illuminated?

This may stop the machine, as I don’t have a Z I can’t really test it very easily.

You can also check your motor driver have green lights not red…

:smile_cat:

Hi Jack,

Thanks for trying to help me it is appreciated.

The rotary is not connected.

I don’t believe I have disabled the boot sequence, is this something I could have done by accident (By mashing buttons or something)? How would I check this is activated?

I noticed this but haven’t yet dug any deeper, now I know this may have something to do with the other axis not moving, I will do some error-checking to see if I can find out why I am getting this reading and let you know what happens.

Both motor drivers have green lights:

If the head is in the middle and you power it up, does the head perform a home operation? Does it move at all?

Check the Ruida for led 13 illumination … this indicates an internal hardware failure.

:smile_cat:

So I have just been out to the workshop and been playing around with the machine again. I’ve made some positive progress, I played with the cables swapping the plugs on the drivers. I managed to get the Y-axis to move correctly using the controls. I continued to switch and swap seeing what I could figure out.

Eventually, I worked out that no axis would work when plugged into my X-axis Driver but all worked (Even my rotary) when I plugged them into my Y-axis Driver. I labeled everything up for future ease.

When everything is plugged in as shown in the picture above and turned on the Y-Axis does home as it should but there is no movement from the axis plugged into the X driver. This leads me to believe there is a problem with my X-Axis driver and it needs replacing.

Would you agree with this or do you think there are some other tests I need to do?

My ULimit- is still illuminated on my diagnostics page but I can’t seem to find any reason for this but it doesn’t seem to be an issue that is having any effect on axis movement.

To answer your questions:
Previously I had no movement at all but now I have a home movement on my Y-axis but not my X-axis (X doesn’t move at all).

The 13 light on my Ruida is not lit.

Thank you again for your help.

Seems you isolated it after the controller and to the X axes motor driver.

Did you plug the Y axes motor control cables into the X axes motor control driver?

Ensure you swap the motors themselves separately and see if you can isolate the issue to the motor itself.

What motor drivers are they… can you post a link… can’t read them with my old eyes.

:smile_cat:

I did all combinations of cables with plug 1/2, X, Y & C-Axis in X driver and the all combinations in the Y Driver. There was never any movement when using the X driver but there was movement with any axis when using the Y Driver.

2DM542 is the driver.

You can swap only the motors by swapping only this connector with the other motor driver.

This will swap the motors wires and tell you if it’s the motor or motor driver.

If after swapping, the same axes fails, then it’s the motor.

Make sense?

:smile_cat:

Yes I understand, I have done this and all the motors all seem to work as they should when using Y Driver. So I’m thinking it must be the X Axis Driver itself.

I have found a replacement driver but will have to wait for it arrived before I can provide you the results.

Do you know of any useful guides on machine maintenance/setup ect. That I could be getting on with while I wait for the part? And do you think my laser tube is likely to need replacing as it is around 3-4 years old?

I want to make sure the machine is in top condition before using it!

Thank again Jack.

When doing any kind of alignment, always check the output of the tube. This tells you if your tube is resonating in TEM00 mode… This simply means the power is distributed across the beam correctly. Tube can go out of tem00 mode or they can just get less powerful. They can probably do both, but I’ve never seen it.

I cut these targets out of water color paper…


The only maintenance is keeping all the mechanical parts good and snug along with belts. If it doesn’t move, it’s likely not a problem.

I try to do it once a month, but it depends on how much you use it. I wipe down and lubricate all the bearing surfaces with white grease. Clean the optics, then do an alignment… once alignment is OK I go back and clean off the mirrors’ debris collected from the alignment exercise.

A check of the alignment is pretty fast, a couple minutes … a complete alignment on mine takes about 15 minutes from all loose mirrors.