NEJE Master 2 - GRBL connection

Hi all,
I purchased a new NEJE Master 2. In short… The NEJE App is very limiting, it doesn’t give you a good control. I want to send a job that I can say, full power cut for certain lines, low power vector engraving, photo engraving… all in one go.
I know Lightburn can do that, but not with NEJE. Is there a trick to do it?
I also have an old PC, very slow, Windows 10, I managed to use NEJE App there, but Lightburn is the goal. Even if it’s to create G-Code from Lightburn and import in the NEJE App… if possible.

It’s possible that you can update the firmware in the NEJE to use GRBL instead of their custom firmware. If not, the only option would be to create a GRBL-M3 device in LightBurn and use that to save GCode to try with it. That profile in LightBurn is the simplest.

Thank you for the quick response.
I tried saving the gcode from LB and import as .nc in the NEJE App, but it didn’t recognise. Same for the M3 and LPC.

Perhaps, it’s a simple change in LB to, at least, get it to export the files.

I don’t know yet how to upgrade the firmware, I can try to figure it out.

I noticed they have but controllers running. When NEJE app is connected, 2 LED lights turn on. When I got LB with GRBL connected, a different set of LEDs came on.

Do you know what I’m talking about?

The beginning of the G-code (.nc) that works from Inkscape with the NEJE plugin looks like this:

G0 X23.0414 Y77.6581

G1 F30.000000
G1 X34.9888 Y77.6581
G1 X34.9888 Y64.4307
G1 X23.0414 Y64.4307
G1 X23.0414 Y77.6581

G0 X20.2679 Y70.6177

G02 X19.7191 Y67.9336 I-6.8382 J-0.
G02 X18.1433 Y65.6394 I-6.4913 J2.7703
G02 X15.8002 Y64.1163 I-5.0453 J5.1982
G02 X13.0141 Y63.5773 I-2.786 J6.9299
G02 X10.2281 Y64.1163 I0. J7.4689
G02 X7.8849 Y65.6394 I2.7021 J6.7212
G02 X6.3092 Y67.9336 I4.9156 J5.0645
G02 X5.7604 Y70.6177 I6.2894 J2.6841
G02 X6.3092 Y73.3018 I6.8382 J-0.
G02 X7.8849 Y75.5961 I6.4913 J-2.7703
G02 X10.2281 Y77.1191 I5.0453 J-5.1982
G02 X13.0141 Y77.6581 I2.786 J-6.9299
G02 X15.8002 Y77.1191 I-0. J-7.4689
G02 X18.1433 Y75.5961 I-2.7021 J-6.7212
G02 X19.7191 Y73.3018 I-4.9156 J-5.0645
G02 X20.2679 Y70.6177 I-6.2894 J-2.6841
G1 X20.2679 Y70.6177

G0 X0.000 Y0.000

This is a circle and a square.

I’m really invested to get this working.

I have looked in lots of places now…
Fusion 360, Illustrator to g-code plugin… other conversions online. Nothing creates a good G-code (if any) to use on NEJE.
DXF files are no good, very few versions are compatible and all software I found only exports the incompatible ones.
Could you provide a solution?
Even if it is to create a decent G-code for cutting (.nc) that can be imported on NEJE app.

I think you got the answer above in a previous reply.

the g-code produced is not compatible. It needs to be in a specific way as per the sample I sent above. Or it comes with “g-code not found” when trying to import it.

LightBurn does export the files and they are compatible…with official grbl. You can check that the code produced correctly by using an online gcode simulator. Here is one we regularly use to spot check for issues:

Your firmware is not standard GRBL. You will need to do whatever edits are required to support this non-standard setup using an external editor OR,

Whatn you say the NEJE “didn’t recognize” - did you get anything more specific than that? Did you create the GCode file with a .nc extension from LightBurn?

The commands you show in the NEJE compatible gcode look the same as what LightBurn outputs. The only things I see that are different are the spaces between codes. If you add spaces to GCode output from LightBurn for a simple square, does that work?

On the Neje app, they have a not saying.
The following G code will be ignored in the NC file

  1. G0 (seek)
  2. F (set feed)
  3. M03 (laser on)
  4. M05 (laser off)

we support G code:
G01 X___ Y___
G02 X___ Y___ I___ J___
G03 X___ Y___ I___ J___

not support
G02 X___ Y___ R___
G03 X___ Y___ R___
and others…

The G code Inkscape created via NEJE’s plugin starts like:
G0 X9.6448 Y13.9052

G01 X9.6303 Y13.9138F30.000000

The code from LB starts like:
; LightBurn 0.9.11
; GRBL device profile, absolute coords
G00 G17 G40 G21 G54
; Cut @ 100 mm/sec, 20% power

LB: G1X00.00Y00.00
Neje: G01 X00.0000 Y00.0000

NC Viewer plots both the same way, but NEJE rejects it saying:
“No G code found”

I changed the G code to match the G01, it produced errors, but it accepted the code.
The errors were produced by single coordinates, LB square drawing sends a X OR Y code to move the laser, NEJE requires X AND Y to move.

I’m also attaching the plugin the exports the g-code for Inkscape.

Only if you could somehow use the code in LB, that would be perfect.

We are getting there.


I just tried a few more options to narrow down the format that works.

G01 X40.08 Y51.57 (works)
G01 X40.0008 Y51.0057 (works)

G01 X40.0008 y51.0057 (works)
G01 X38.92Y52.01 (No G code found)
G1 X40.08 Y51.57 (fail)
G1 X40.08Y51.57 (No G code found)
G01X40.08Y51.57 (fails)
G01 X40.08 (error)
G01 Y40.08 (error)

Fabio, in my experience, the Neje Windows app overrides the speed and power for all GCode. It will draw correctly, but never change power settings. In order to manually control the speed and power, you must use the 2nd processor of the Master 2 that uses other apps. This is where I hit too many errors regarding homing. Are you seeing the same or are you able to vary your power and speed in a single GCode using the Neje app?

Hi BlacjjackDuck,
Talking about NEJE App importing G code here:
Power and speed G code is ignored.
It’s the format of the G code that is causing the fail here.

The GBRL interface just doesn’t work.
I tried to type some bits of code on LB interface, it does do what you expect, but the feed-back is not there. You can’t get homing, current position, reset… it’s just not working.

What I’m trying to pursue here is to use LB as Inkscape, an G-code generator for the complex drawings. then using the NEJE App to send to the machine.

I saved the G code as .nc

Hi again,
I had another go with GRBL now. As homing doesn’t work, I tried to position the laser where home is and turn on the controller (LB).
Jogging was ok, preview seem to work, I got it to cut and it just followed the lines with no cutting power to the laser. I managed to control the speed, but the laser on and off was not working.
To replace the controller board, is it just plugging the hardware cables to the new board? will they all work?

maybe this is helpful… ie putting GRBL 1.1f on it:

Hi DougL,
The machine already has the GRBL 1.1f on it.
But I’ll dbl check.
Also, everyone there have the same problem. No homing, no laser power control, burning on travel…
One thing I noticed is Neje takes code with a particular way and fails to recognise any other g code syntax.
G01 (can’t be just G1)
G01 X999 Y999 (it has to have a space between the G01 and the coordinates)
I’m assuming here that the M5 or M2 power on and off would have to be M05 and M02 to work.
Maybe NEJE did this on purpose.

That is not GRBL 1.1f then since I can enter G1 X5 Y5 or G01 X5 Y5 and it moves fine.
This is on Ortur with GRBL 1.1f

If NeJe modified GRBL that much, it’s time to put stock GRBL on it.

regarding M3 X100 not working they might have wired the laser PWM to something other than the spindle control. Maybe a fan control or hotend control. I would look for GCode to change Fan speed and see if that turns the laser on/off. Also look for GCode for hotend PWM and try that.

I’m still fiddling here.
I installed LB on my Mac, got the driver working to send GRBL to the machine.
Straight from LB won’t do much other than moving the laser head.
LB send M9 and M4. NEJE does nothing with that so far.
Also the job hangs for a while after the cutting “G1S0”
After changing the code, I managed to cut with full power using M03, I can control the speed too.
This is what I changed.

I changed the original code:

; LightBurn 0.9.11
; GRBL device profile, absolute coords
G00 G17 G40 G21 G54
; Cut @ 6 mm/sec, 20% power
; return to user-defined finish pos
G0 X0 Y0


; LightBurn 0.9.11 (saved GCode and modified till sucesseful using the "Run GCode)
; GRBL device profile, absolute coords
G00 G17 G40 G21 G54
; Cut @ 6 mm/sec, 20% power

; return to user-defined finish pos
G0 X0 Y0

If you can’t send commands via the Lightburn console something is wrong.

If you can and you can send
G01 X20 Y20

but you can not send
G1 X20 Y20

You need to replace the GRBL firmware and then continue.

I managed to send the code via the “Run Code” on LB.
No luck yet controlling the laser power.
S is not doing it.