Neje Master - Can't get homing working

Hi everyone,

i’m new to laser engraving, lightburn software seems to be very powerfull so i would like to give it a try.
I have a Neje Master 20W laser engraver, and the default software is just crap …
Currently i’m able to connect to my laser engraver, i can start a job, move axis but, and that’s the big deal, i can’t get homing working.

When i try to home my X and Y axis, nothing happen, the motors make a little noise and then nothing move.

here’s my parameters in my GRBL firmware

$0=10
$1=25
$2=0
$3=1
$4=0
$5=0
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=0
$21=0
$22=1
$23=0
$24=25.000
$25=500.000
$26=250
$27=1.000
$30=1000
$31=0
$32=0
$100=40.000
$101=40.000
$102=40.000
$110=500.000
$111=500.000
$112=500.000
$120=100.000
$121=100.000
$122=100.000
$130=200.000
$131=200.000
$132=200.000

Can someone help me find a solution ?
thank’s by advanced.

I’m not sure the homing switches are supported in anything but the NEJE firmware, which isn’t compatible with LightBurn. I’ve got one of these myself, and have emailed them to ask about it, but with Chinese New Year holiday happening I’m not expecting an answer for a bit.

I’m very hopeful for a collaboration on this front. Any news from NEJE so far? How could I keep up with that without bugging you every 29 days? :wink:

Btw. LightBurn rocks.

Thank you for these kind words. :slight_smile: We can only hope for a speedy response, but given the issues pointed out above… :man_shrugging:

You should be notified when this post is updated or anytime @Schneenagels is used in a post. This should save you the trouble of checking back, although we do like hearing from folks!

I’ve heard nothing back from NEJE, no.

Hi All, I too am a NOOB to laser. I own the Neje 20W, which I have flashed with GRBL 1.1f - but I too get error 5. I took the opportunity (the site was very good to point me to some posts already done) to read through the help files but here is the crux. I am not sure if they are referring to LightBurn or GRBL(not even sure I have just GRBL anywhere on the laptop… when they say to check config.h file parameters. If I turn auto home off then it appears to work but I cannot use the home button. I know there are limit switches on the hardware - I guess all of our questions are - how do we make Lightburn or the GRBL DEVICE recognize them (YUP still not sure on the separation as well :frowning:)

All LightBurn does is issue $H to the device, and GRBL takes over from there. I have one of the NEJE engravers, and it has limit switches, but they appear to be ignored by the GRBL firmware on the device. Error 5 means homing isn’t enabled - you’d have to turn on homing in GRBL and then configure it to home and detect the limits, assuming that they’re wired to the correct pins.

Setting up homing: https://github.com/gnea/grbl/wiki/Grbl-v1.1-Configuration#22---homing-cycle-boolean

Thanks Oz! I read through that and while I understand the words I lack the necessary GRBL Education to know where to go to Check out config.h for more homing options… for example. This maybe very basic stuff I am asking here and my apologies for that. I see someone has gone to Neje already to ask NEJE about the switches but with the COVID-19 stuff going on may be some time before we see a reply. I would like to educate myself further - are there any reference materials that someone can review that start at GROUND 0? This is NEJE (I did read the owners manual), This is GRBL, This is the DEVICE DRIVER that Lightburn uses to speak to the DEVICE - This is how GRBL interacts with Lightburn device driver and then this is how Lightburn sends commands to GRBL which in turns passes them to the DEVICE? I hope any of that makes some sense… and of course after all that I need to learn to use Lightburn :slight_smile:

There really isn’t, unfortunately. GRBL is the firmware, and the docs for GRBL will cover all the configuration and usage of it. LightBurn’s GRBL driver just sends gcode (and GRBL) commands to the device. Homing is handled entirely by the board / GRBL. It’s possble that NEJE didn’t connect the limit switches to the proper pins for GRBL to use them - I can’t say until NEJE responds.

I am about to tuck this away i think… I built an enclosure with air in and air exhaust fans works great. So I moved onto the Lightburn sofware (after extending my trial - Thanks Lightburn!!) … Love the Software so intuitive (after a few video tutorials)! But I cannot seem to find a driver that will allow me to vary the power of the laser between cuts … I put a circle in a square and was able after much playing to get it to etch the circle and line the square … but all done at FULL POWER… so I put some text in …again all done at full power …I tried several different GRBL devices but all amount to same thing… no real control over the NEJE 20W laser flashed with GRBL 1.1f … guess I need a different laser!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.