New BJJCZ Ezcad 2 with rotary board keeps randomly disconnecting during jobs

The board does a couple of jobs okay and then keeps randomly disconnecting. In Device manager the card disappears and then refreshes to show the card. The card is the newest V4 new style fiber FBLI - B - LV4 Model A

I’ve tried different cables, different laptops all on mains power, sorted out USB properties to stop it going to sleep, changed the 5v power supplies 3A and a 7A tried. My old board runs great no issues but no rotary function. It is powered directly from the usb cable so doesn’t need the 5v power supply but this show that the device manager entry is fine and so is the usb. Any ideas ? Faulty board ?.

I don’t have specific experience with this board - though this forum thread may be of interest: Trouble Installing FBLI-B-V4 controller

TLDR: How did you install the LightBurn driver, and have you checked to verify it’s still in place?

You may want to do the Zadig method of install - Galvo Installation - LightBurn Software Documentation

This is the options to try provided Cloudray.

  1. Replace the USB cable and take a look

  2. Change the USB interface of a new computer or switch to a new computer

  3. USB cable directly connected to the board

  4. Adjust the 5V power supply to 5.4V

If there are no issues with the above checks, then there is a problem with the board.

I have tried all the option except the power supply mod, which I am looking at doing soon. Should I be worried about increasing the voltage?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.