New Issue with run boundary on Snapmaker

I am running a Snapmaker 2.0 A350. Which as far as I can tell is marlin-based, but its own flavor.

I have followed the Snapmaker setup guide here on the forum, which seems to be an older version of Lightburn, and recently run a series of nearly-identical jobs that worked just fine.

On the last Job, I started to have an issue where layer 2 would not engrave in the correct position. (using user origin and setting origin at the center of the workpiece) even when the frame did not include the part where the second layer engraved.

I tried changing to “absolute coords” per the guide and another user’s recommendation, but then framing the boundary began to send the laser to a certain location and freeze. I waited for it to finish, but Lightburn kept showing “busy” even after hitting stop. The machine was still frozen even using the manual controls. The only way to stop this behavior was to restart both the machine and the software.

So then I tried to go back to user origin, and I get the same strange behavior when I run boundary (square boundary) in Lightburn.

Any suggestions?


I have confirmed there is not any offset in my workspace and I am using native workspace using M1007.

The console does not show anything after starting the frame.

The frame freezes the machine, but the job seems to run ok on 1% power at 3x speed.

When running the job and then pressing stop in lightburn, the machine freezes and I have to restart the machine as well as lightburn in order to get back up and running.

I have tried reverting back to last known working version of lightburn. (1.0.04) and going back to most recent. Nothing changes.

I tried updating my machine firmware. I have not yet reverted firmware back, but I don’t expect results with that.


I’m not familiar with the Snapmaker and not very familiar with Marlin but willing to see if I can help.

Some questions to gain my bearings:

  1. Does your machine go through a homing process?
  2. If so, to where does it home?
  3. After homing, where is 0,0 with respect to X,Y?
  4. Are you using the Z axis when lasering? What happens to Z after homing?
  5. Is this a dedicated laser machine or do you use this also for 3D printing and CNC operation?
  6. If you do use for more than laser, what is the process for converting the other use?
  7. Are you now stuck in the water? As in you can’t burn at all?
  8. If so, is this not working for 3d printing and CNC?
  9. Do the jog controls in Move window work as you expect? Left moves left, right moves right, Z controls work, etc?

Can you send screenshots of the following:

  1. Device Settings window
  2. Full Screenshot of LightBurn preferably in a situation where things are not working as you expect

Are you able to include the .lbrn file that you’re using also as reference?