New Material Test Generator Question

So, the Material test generator is an awesome new feature for engraving tests. However, is there a way to have it do cut tests? I’m not seeing how to set it to cut instead of engraving



You can edit the Material Settings, and change from ‘Fill’ to ‘Line’. :slight_smile:

1 Like

Awesome :slight_smile: Thank You :slight_smile: I totally overlooked that dropdown

1 Like

Ok…One more question :slight_smile: how do you make it preform the test at the origin location

The Material Test should be using the ‘Start From’ currently set in Laser window. :slight_smile:

1 Like

Awesome :slight_smile: Thanks

So where is this?

I don’t seem to see it on 1.1.00


Seems to be a new Menu header for tools:

Looked in ‘Window’…

No option, same version…?


The screenshot is from newly updated 1.1.00 on Windows. I previously did not have the Laser Tools menu item. These would have been under Tools previously.

Will there be a tutorial or some sort of help for this? I seem to be having a hard time getting the letters to be lines and the squares to all fill at once.

There will be, yes. Please remember, we are a very small team, so we wanted to get the code in your hands as fast as we could. :slight_smile:

At the bottom-left of the ‘Material Test Generator’, you will see edit buttons where you can change the layer output from line to fill and also set how the fill is produces, just like all other work defined in LightBurn, but just for that test.

We appreciate all your hard work and thank you for getting it all packed into a nice neat upgrade. I look fwd to the help sections. I have been playing with the edit buttons but they are not working for me the way I want them to. I may uninstall and reinstall. Thanks again.

If you provide a bit more detail about what “not working” means, we may be able to assist further. :slight_smile: What are you wanting to do, exactly? What steps have you taken, and what did you observe? What did you expect and what did or did not happen?

Screenshot 2022-03-04 024702

So all it does is the numbers and letters by filling and not line. Then the scales are not filling all at once and no matter what, my speed does not change.

I think you have got the settings the wrong way around.
The black layer is for the material, which in your example should be set to fill and ‘fill shapes individually’, the blue, for the lettering should be set to line

1 Like

For my part, what I noticed and which is causing me problems in the configuration of the test generator is that the speed is expressed in mm/s and not in mm/min as configured in my configuration parameters

This is known and will be addressed soon as well. The Material Test generator was originally for galvo devices only, so the units were always mm/sec.

1 Like

I use the XTool D1, so the mm/s is easier to work with that mm/m, but my Dad is in his 70s and his Atomstack is best used in mm/m… He’ll definitely appreciate it if the units were selectable (maybe also include an mm/s or mm/m in the Speed caption?). By the way, I LOVE this generator. Much easier than rolling my own or using the online one that creates a new project.

The update with this fix has already been posted. You can download it now.

1 Like