New OMTech laser not connecting to Windows Surface 8 w/ Windows 11

Tried several ways to get this to work. Uninstalling Lightburn and reinstalling checking the box for drivers the FTDI drivers, connecting the USB before and after the start of the program and so on but Lightburn softward is not finding the laser. I finally tried setting it up manually as one kind individual suggested but that’s not working either. I was told they had to set it up manually and then Lightburn would communicate to the laser - but I’m either really dumb (meaning I’m not understanding the steps) or somethings not working like it should.
I did search prior to asking but found nothing recently that might be of assistance. Most posts like this were from nearly a year ago when Windows 11 wasn’t around. I wonder if that could be the issue. btw, my laser is an OMTech MF2028-100 and I am using a Windows Surface Pro 8 with Widows 11

I think this is not a lightburn problem.
Does your OMTech has no ethernet? I use ethernet on all machines and this works much better than USB. If you have - have just to to your controller - setup an IP address of your local network… open lightburn an add new machine + by choosing ethernet - put in IP - and ready.
If not - the problem is the FTDI driver. There are a lot of different version for the chinese chipsets … sometimes only a special single one is working.
Try some other drivers - maybe download from Thunderlaser… you can also download free RDWorks there - just to make sure the problem is only the driver. RDwork does not need any machine setup - just start it and your device has to be shown…if not … go back to the FTDI driver… if you fix this … lightburn will work and find your machine.

4 posts were split to a new topic: OMTech Laser not connecting (no Ruida option in LightBurn)

It does appear this is a main board issue. I installed RD Works and also could not get it to talk with the laser. Omtech is sending a new main board with hopes that resolves the problem

To update and for future assistance - I found out my SurfacePro 8 was the issue and not the mother board or even user error as I suspected. When I tried another computer, an actual laptop full sized, then it worked fine. I’m curious to know as to why my SurfacePro 8 wouldn’t work though. I’ve purchased an inexpensive laptop to run the laser on.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.