New power issues which make zero sense

So my 100watt C02 laser, just installed a mA meter. When i put cut settings in lightburn, set the artwork to line. At 47% i get 14mA no problem and its very consistent power, when it come to engraving something wierd happens…

  1. at 20% to 40% ill he lucky to get 3mA

  2. from 40% onwards… it spikes between 1mA to 13mA but no consistency in any power level above 40%
    I will visibly see the spikes in the engraving, deep lines to very shallow lines with each pass…

Engraving for me is restricted to using 30%, max 33% for a clean engrave…i cant go below or above that.

My alignment is spot on, dot on dot…close and far. And the beam runs parallel to the rails.

I am utterly lost

Did this issue appear only after installation of the ammeter?

How did you wire the ammeter?

No, its been there for a long while…but now that the mechanical Am meter is in, i can actually see what is going on.

What are your specific cut settings and what are you engraving?

Also, can you separately describe the issue that led you down this path? Want to make sure you’re not chasing down a phantom of current when there’s something else fundamentally wrong.

So if im cutting 5mm clear acylic, im running around 14mm/s at 48% power (around 14.6mA)

If im engraving anything its what ever speed to get a clean engrave at 30 to 33% power. Depending on stock…
If its mdf im around 150mm/s at 33%

What types of designs are you engraving? What are you using in terms of min power?

Separately, is there something about the power level that’s making you question whether something is wrong?

I’m trying to narrow down what problem it is that you’re solving for.

So i struggle with the most basic on engraing…a simple 20mm x 20mm square would cause all kinds of problems if i was to try and go below or above 30% power. Lets say im doing very hard wood, but the customer requests a deep engrave. At some point if id like 35% power…itll start doing the acutal issue of spluttering power. Ie…deep one like of pass the next being silly shallow…

I want to make sure I’m getting the facts right.

Are the results relatively consistent with a given power and speed? Or do the results change even with the same settings?

If the issue only manifests when changing speeds, is there a pattern to the change? This is the part I’m not clear on.

Are you saying that power peaks between 30% and 35% and power becomes weaker beyond those ranges on either side of those values? If this is the case, can you build a material test here, run the test, and then send both the .lbrn file used and a photo of the results?

Lightburn PowerScale Generator - O2 Creative

It looks like it’s got some backlash…

Do you have a voltmeter and any knowledge of electronics so you can measure a few things and let us know? A scope would be preferred but I know that’s not a common household item. :face_with_spiral_eyes:

The mA meter is helpful and indicates the lps, but the control signals are really what we need to look at.

  1. What is the lowest ‘power’ your tube will lase?
    Larger tube will generally require higher percentage of ‘power’ to lase.
  2. Check the tubes resonance beam at the m1 position.
    You want TEM0 resonance.
  3. ‘gently’ tug on the wires from the controller/lps and ensure they are inserted and screwed down. Sometimes they are held in place by just the glue… :frowning:

The controller only communicates to the lps via CN5, that or the lps would be the only real places a lose wire might be an issue. N and L are lps inputs.


So if i want a smooth bottom on my engraving, with no high and lows which to me represents a ‘spike and drop in power’ i set my engraving piwer to 30 to 33% in lightburn. Anything above thay will create these spikes and drops which you can see in the images i sent…those images were done at 37% power. Its consistent and i can see my mA jumping between 1mA and max 3.6mA…which to me is very lower for set power.

Even when cutting i have to be above 40% anything below that and my machine makes a crackling sound at the nozzle, and cut maybe 1/3 through 3mm mdf.

I do have a multimeter, but i generally use it to test for ground and shorts. Thats as far as my knowlage goes. With them.

  1. lowest power is 15% to test fire enough for a clean burn mark

Ill read though the Tem01 test and see how best to do it and report it back here.

And also have a good look at all control wires and see if i can find any loose ones

That’s probably enough to get us some basic information.

There are a couple ways to connect the power control to the IN terminal of the lps. The most common is the LPWM1 to the IN of the lps… Sometimes L-AN1 (analog of the pwm) is wired to IN of the lps.

  1. Do you get a good TEM0 burn at m1?
  2. Can you do one of your rectangles at 50% power while measuring the LPWM1 output… this should go to the lps… There is no need to power up the lps…
  3. The voltage should be about 2.5V and not vary while it’s doing the filled square.
  4. Repeat this again at your problem power levels…

A couple things…

The Ruida sends the specified pwm the entire time that layer is executed, so it should be consistent. The laser is fired by the L-ON1 interface. I.E. Laser on or laser enable…

When the Ruida is in ‘scan’ mode, minimum power is not needed as the head will always be at speed when it’s required to lase… The hardware in the Ruida computes the overscan when you attempt to execute the job … this is where the machine can gripe about ‘slop’ error or something similar.


Did the laser test i think…not quite sure if i did it right

So the larger rings are 50% power at 100ms pulse

The smallest of them was at 20% at 500ms

The mid size was at 30% at 300ms

This is how my controller is wired up

What i cant get my head around is at 25% i get a reading of 3.5ma consistently…if i change the power to 40% it hovers around .9 to 1.6ma, sometimes down to 0.1ma

“Crackling sound at the nozzle”, weak/inconsistent output?

Sounds like you are leaking high voltage power which is not consistently making it to the tube.

Check for sign of arc damage all along the high voltage wiring, try to get a bit closer to the High Voltage Power Supply Unit (just not too close) set the engraving power output to 37 or where it is bad, my guess is you will find (listen for a crackling frying pan sound) that the power supply is internally arcing.

Is the photo from the tubes beam onto m1?

It looks like a failing tube, if this is true…

I cut these out of watercolor paper for alignment… the target is from m2 and is a combination of a far/near burn.

It looks like a failing tube, if this is true…

Your system is wired to apply an analog power control to lps IN instead of the pwm … many do this…

Although not relative…

It appears the water protect is wired to P on the lps?

If this is the case, I’d move it to WP1. The reasoning is …

  1. With a coolant failure wired to the lps, it will protect your tube by stopping the lps from firing. However the controller won’t know it and will keep executing the layer not knowing the laser isn’t firing.

  2. Wired to the controller, it will not only stop the lps from firing, it will retain the failure location and allow you to fix it problem and continue…


Yea, all 3 pulses where done at Mirror 1. Iv been suspecting the tube. And to counter that, i just purchased and received my new tube. Just waiting on a new power supply to arrive, so i cant put both brand new in the machine and see if my troubles disappear. Ill keep this setup for emergency back up if necessary.

I suspected mine was wired differently when i had a look at the image you posted…thought it might be of significance, so decided to let you have a look.

Thanks so much for your help…though not entirly solved…i do have a back up incase the proverbial hits the fan.

Strange how oddly this effects how the machine works…

The idea of a good resonance is a nice brown spot on the target from the tube… if that’s not right your hands are tied…

  1. properly working tube
  2. aligned and clean optics
  3. focus

If these are OK it will work…

I’ll be waiting for your tube to arrive… what/where did you purchase?


Tube is already in, its the lps im waiting on. Purchased a Reci tube from a registered dealer in SA. I suspected it might be the tube. As its been like this for awhile and nothing i did or have tried to do makea it any better. I do a lot of acylic engraving and cutting, tons of ‘neon’ signage. So the top end of the tubes power is fine for doing the grunt work till it fizzles out finally. I have a second older Trotec that does fine detail engraving. Rf tubes…you just cant beat how clean they engrave :stuck_out_tongue_closed_eyes: