New setup of TLC Rotary spins and spins does not complete simple rectangle

I have a K40 Mini with a C3D Laserboard and just added a TLC Rotary.

I went through the C3D setup and think I have set things there reasonably well, one rotation is as expected on my direct drive wheel. The rotary is connected to the A axis on the C3D Laserboard and
A axis is selected in LightBurn’s rotary setup.

In trying to dial it in, I followed along with a well made video tutorial on the setup and calibration
As described, I created a rectangle half the circumference of my glass about 24x135mm.
After marking the half way lines on my glass and lining it up under the laser with the led on the line, I started the job (using Current Position and bottom center for the job origin) when it began it jogged left as expected and then started spinning and never stopped to execute the rest of the corners and the job never finished?

A clue may be that it said “Cut may be out of bounds” Continue anyway?

Any suggestions?

Cut out of bounds means the code will drive the head out of the defined working area.

You need to think of the rotary as a ‘flat y table’. If you start a job that takes the full size of your bed and start it from the middle of the table, it will have to go out of bounds to complete the work.

This may include if the head has to reach a certain speed and it doesn’t have the room to do that.

In lightburn, the ‘test’ button in the ‘Tools → Rotary Setup’ does one rotation of the driving wheel?

When you set it up, depending on how ‘Start From’ is set, it has to be able to move the complete distance, it doesn’t know it can rotate forever…

Can you drop the .lbrn2 file… It should be simple…


Hi Jack,
In the rotary setup, when I test it does do one rotation, 360 degrees. It is a direct drive wheel.
Start from is set to use Current Position and bottom center for the job origin.
I appreciate you help!
Here is the file:
Rotary Test.lbrn2 (4.5 KB)

15 mins later… For giggles, I just tried creating a rectangle 2x6mm and now I am getting close to moving 135mm on my glass that has been marked half way around and finishes as expected, no out of bounds warning this time.
This seems like progress but I am still not sure where the problem is or what needs to be changed to fix this…

If the rotary makes the ‘driving wheel’ one rotation when ‘test’ is clicked, then it has to be one is in different ‘unit’ like, inches or mm.

The software is showing that the hardware/software is ok.

If you look at your Machine Settings is the ‘Report Inches’ setting correct?

Screenshot from 2022-02-13 06-58-52

Your file, shows it is 135mm in height… ‘Select’ the object and you can read the size…


I do not have, or can not find Machine Settings in my setup, when the machine is on and connected, there is no menu item listed for them under the edit menu. Also when I try the $$ command in the console I get error: invalid statement.

Maybe this is because I am using a Cohesion 3D Laserboard?

I am not that familiar with the Cohesion, as far as I knew it was a grbl controller. I think you can change some of it via a script. Your settings might be elsewhere…

Might check out this thread, as the lightburn people have referred others to it…


Thank you @jkwilborn I have reviewed the sections on the C3D forum mentioned and nothing so far that I have read there is pointing to a solution.
Any rectangle I create in LightBurn that exceeds 81mm is giving me the out of bounds warning.

As I mentioned earlier, a rectangle of 2x6mm in LightBurn is spinning the glass 135mm which is the dimension I am trying to achieve but it should be 2x135mm in LightBurn equals 2x135mm on the glass.

I posted on the C3D forum about not being able to view the machine settings from within LightBurn
Hopefully Something will be revealed from that.

I guess I’m not following you. It’s supposed to be a 2x6mm, but it’s drawn as 24x135. So I expect it to be 135mm around. That is what you are saying is wrong?

I guess I don’t understand the issue properly.


Sorry, you are correct. I changed the file locally to 2x6mm, trying to trick the software by changing the rectangle length in LightBurn into giving me 135mm on my glass. And that’s what it does if my rectangle is 2x6mm.

If I create the rectangle in LightBurn at any length above 81mm, let alone 135mm, I get the out of bounds warning and if I hit continue anyway, the spinning endlessly behavior starts. I have also just noticed that when that happens, there is a momentary pause of the drive motor at regular intervals as its rotating the glass.

I think you may have exhausted my knowledge on your board. I have some standard grbl controllers and a Ruida…

Lets hope someone else drops in…

Good luck


Thank you again for your help @jkwilborn, you have done a great job of pointing me in the right direction.
I will post back here when I have updates…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.