What would make lightburn give an out of bounds error on an 82mm or more height rectangle?

I am trying to set up a new TLC Rotary and going in circles trying to figure out why it’s not working.
I have a K40 mini with a C3D Laserboard running smoothie and have been through the documentation both here and at the C3D forum here.

The rotary is connected to the C3D Laserboard’s A axis and set as a roller type and to use the A axis within LightBurn’s Rotary Setup. As I have the Smoothieware configured, when I press Test in the rotary setup, I get the expected one complete 360 degree rotation.

One of the problems I am encountering is that any rectangle created in LightBurn of a height over 82mm is giving me an Out of bounds warning, and if I press continue anyway, spinning my glass way beyond what it should.

What might cause this out of bounds warning to happen?

These are my other posts trying to get to the bottom of making this work…
LightBurn Forum:
New setup of TLC Rotary spins and spins does not complete simple rectangle
C3D Forum:
Machine Settings not available under edit menu in LightBurn

Any help is appreciated…

Can you take a full screenshot of LightBurn with the warning message?

You said “the rotary” - is it a roller or a chuck? If it’s a roller, when you press the ‘Test’ button, is it the roller turning a 360, or the object sitting on the roller? (It should be the roller)

Picture of the warning…

I believe it is a roller but a picture may help:

Here is how I have the settings in LightBurn:

The roller drive wheel is turning a full 360 on test as expected:
Hope this helps…

the 1.1mm roller diameter (thinner than a dime?) seems a little bit suspect.
11mm is close to 7/16"

1 Like

Good Catch @JohnJohn, I was following a video during setup of the same rotary and did not notice that the maker had his interface set to inches. I have now changed the roller diameter to 28mm and confirmed that a test rotation still gives me 360 degrees from the rotary setup.

I am still getting the out of bounds warning. I am also observing momentary pauses of the drive motor at what looks to be 10mm intervals during the course of running the long end of an 80mm rectangle, which I can run without getting the out of bounds warning.

Here are the A axis settings of my C3D config file in case they can provide any clues:

# A axis
delta_steps_per_mm                  22.50             # may be steps per degree for example
delta_step_pin                               2.3              # Pin for delta stepper step signal
delta_dir_pin                                0.22             # Pin for delta stepper direction
delta_en_pin                                 0.21            # Pin for delta enable
delta_current                                0.6               # Z stepper motor current
delta_max_rate                           6000            # mm/min
delta_acceleration                      100              # mm/sec²

Do you possibly have another object sitting outside of the workspace in your design? Press ctrl-shift-a. It should center your entire design.

Just checked, nothing there but my one rectangle…

Irrespective of the error, are you getting the right amount of rotation on your object now? The roller diameter fix should have addressed that.

Revised: Now, after some further adjustment to my C3D config file, I’m getting close to the right amount of rotation on a 10mm rectangle on my glass.

I’m still getting little momentary motor pauses along the length of the rectangle, I can see that the drive shaft itself is pausing.

Does anything in my A axis config file (above) look suspicious?

@LightBurn can you say why LightBurn might be giving me the Cut is out of bounds warning and also possibly any insight into what may be causing these momentary motor pauses I am experiencing during the long side of my rectangles?

You motor configuration may be incorrect. Did you tune the current for your particular motor?

Take a look at this page:
Changing Stepper Motor Currents on the LaserBoard - Cohesion3D

I checked that link and adjusted my current from 0.6 to the recommended 1.2 for the NEMA 17.
No change. Here is a video of the motor pauses I’m seeing.

Almost looks like the motor is lugging. Just looked it up and C3D uses 1/16 microstepping for their drivers. Do you know if that motor supports this?

Either way seems like a potential problem with stepper configuration but not certain.

Actually I am not sure how to tell if it does or not, I did some searching on the subject but did not find any definitive way to determine this. Here are the specs of my drive motor:

Yeah. I’m not getting much from that datasheet either. One thing I notice is that the voltage for this motor would be fairly low (1.7A*1.5ohms = ~2.6V).

You may want to compare this motor to the other ones on your machine and see how they compare.

Another thing I just noticed, When I run the test from the LightBurn rotary setup, I get smooth rotation without the momentary pauses, video here.

@LightBurn, I am also curious how LightBurn determines what would be out of bounds for my A axis, does it use the circumference set in the Rotary Setup window?

Oh, excellent. Then that means at least that it’s capable of running smoothly. I actually thought that was how you were running this before.

Try saving the g-code for the job where it pauses. Would be good to check if the job itself is pausing.

Here is an image of the saved g-code:

My circumference in the Rotary Setup is: 219.911mm