New user offset problem

Hi, have a problem with the below image not coming out right. Have created it in lightburn (not a cad user so took a while), preview is fine but when i go to the laser, the text and first 2 scans come out ok but then it all gets offset to the left.


engraving test400.lbrn (332.2 KB)

Have tried the original on rdworks and it cuts/scans fine. Just on the demo of lightburn at the moment, is the drawing/cad side of it still in development?


Have tried sending to machine and ran from there but no luck.
Have just tried another suggestion to run a slower speed but still not quite right.

see attached.150

Just a stab in the dark (am a laser newb) – when I generate the gcode from your file, between the layers I see G0 movements without specifying a feedrate, which leads me to believe that your machine uses its maximum possible feedrate for those moves. Is it possible that this feedrate is so high that the machine is losing steps when moving from one object/layer to the next?

Again, sorry if I’m completely off with my guess. :slight_smile:

thanks smokesout, you could be right but im a bigger newb than your good self and dont have a clue about gcode :wink:

has been fine for the last couple of weeks, decided to demo LB and create a test pattern and this is the result, shame because i do like LB over rdworks.

just tried turning off output for the text and outline cut but still shifting to the left after the 15% section done.

have just done some engraving on cork coasters for the kids last week with no problems, dont know whats going on.

With a DSP controller like the Ruida, there is no human readable code produced for the machine.

You said you tried the original on RDWorks and that worked fine - did you use identical speed, power, and interval settings? It looks like the machine is slipping - IE the motors are losing position from accelerating too fast, moving too fast, or possibly both.

Hi Oz, just looked now at the rdworks file, all appears to be the same, only difference seems to be the letter engrave speed on LB is set to 250mm and RD is 150mm.

Have just cut RD one and all came out fine, see attached.
will attach RD file as well.

Going to try setting the text engrave from 250 to 150 see if that has an effect.

Changed letter engrave speed down but still shifting at the 20% section, consistently so,seems strange.

Have email you RD file.


Tried a couple more things:

Exported from LB project file to dxf, opened in LB, still the same shifting to the left.

Exported from LB project file to dxf, opened in RDworks and cuts fine ! see photo.

Dont know whats going on, either problem with lbrn project file but when exported to dxf works in RDworks but not LB.

Its as if the origin is moving to the left a set amount twice while the cut in in process.

Dont know why its working in RDworks but not LB, i want it to work in LB :slight_smile:

p.s. have emailed you the rdu file

Have tried to recreate the sketch above and it appears the lines are not joining up.

created basic shape with vertical line

zoomed in to confirm line is connecting to 2nd circle from center

performed circular array on vertical line around center

zoomed in onto array lines that are created but they are not connecting to the outer circle

…zoomed in onto array lines that are created but they are not connecting to the outer circle

dont know if this maybe related to the offsetting in the 1st post or not.

May be able to test an a LB RDufile on a friends laser later this week, will update with results.

That gap is less than 1/100th of a mm. Circles are approximated in LightBurn using bezier curves, to a tolerance of about 0.01mm, so that’s not unexpected.

Hi Oz ,so i need to extend the rays and trim the excess, that makes sense.

p.s. did you receive my RDworks rd file as requested regarding the shifting issue above? (14th march)



Re-created design in LB as above, and all cut fine, no problems. Still , would be interested to know what went wrong with the first design, maybe performed too many actions (convert to path, convert path, close shapes etc).

have sent ufile to dev, so hopefully they can figure it out.

Following I too am experiencing a similar problem

I have similar issues and it’s funny that happened only to a test pattern (similar to the picture). In my case it was fine for the first three then it starts shifting.
Looks like LB prevents the creation of a test sample :slight_smile:

Phew, glad im not the only one ! Thanks jjyotk, lis610. Strange about test patterns, my fear is spending a lot of time designing something in LB and not being able to fix it!
Has to be something in the lbrn file im guessing.

Did a simple test pattern the other day with the same settings but with just simple shapes. Thought i might have too many layers in the original but this turned out fine.

Just managed to test this out on a friends 50w laser today and the same thing.


Only difference is its not shifting over to the left as far as the original . Still moving at the 20% mark though.

Like i say, have sent files to devs so hopefully they can figure it out but only have 12 days left of the trial so time is ticking away!

Shame coz i was hoping to use LB instead of inkscape to design (im not very good with design and LB seems more intuitive).

This makes no sense, tried selecting the 20% fill shape on its own and it cuts in the correct position!
Tried making all the fill shapes a group and start and it goes back to shifting left at the 20% point !

Ruida controller?

What is your Idle Speed Acceleration? (it’s in machine settings)
Idle speed is the speed the laser moves at when traveling between shapes. If the idle speed acceleration is too high it can loose steps and position when traveling between shapes. So individual shapes may look fine, but are not positioned correctly relative to each other.