New user with questions - Laser not turning off between cuts

I started using lightburn opposed to GRBL for my SainsmartCNC3018 Pro with laser engraver because I liked the extra features but im running into this issue. When trying to print a vector or traced image rather than printing left to right in passes the laser does not turn off inbetween shapes and it looks far from optimal. Is there a way to configure the program so that it turns off inbetween shapes?

Yes, and we have covered it many times here in the forum. There is a search tool found on every page here. Look to the upper-right of each page and you will notice a magnifying glass icon. Click that and enter “Sainsmart 3018” and hit return.

You will find several posts talking about this in detail.

Please post back if you are continuing to have issues with your gear.

I searched like you said and I only came up with a handful of topics. None covered this issue.

The laser is staying on due to not having your grbl set correctly. You have not identified the version of grbl you are running so would need to know that to offer additional assistance. What ‘Device Profile’ did you select when you set up LightBurn?

I was using the program LaserGRBL v3.0.24 which was able to print the image perfectly like shown in the image. I will say however I would like to achieve those same results on the LightBurn software so I can take advantage of other features.

LaserGRBL is software and we are looking for the firmware running “on” your laser controller.

GRBL is the firmware running on the little board on your machine. Because it’s sold as a CNC machine, it’s configured for CNC use by default. “Laser Mode”, which is mentioned in the above post, tells the controller that it has a laser attached, not a spindle, so it doesn’t have to pause to let it spin up to speed, but it also has to turn off during rapid moves, which a spindle doesn’t have to do.

Okay I will say that I am a complete newb when it comes to all of this. I assembled this machine a few days ago and prior to that I have had 0 experience using laser engravers. Where can I find what firmware is running on my machine? I will say the laser attachment that came with it included a separate circuit board that runs from the existing main circuitboard. So its main circuitboard -> laser circuit board -> laser.

I simply plugged my PC into the main circuitboard, loaded up lightburn, connected it and fired it off.

After reading this again an hour later, I think I understand what you mean but I am still not sure why the LaserGRBL program included puts it into laser mode but LightBurn does not.

Heres some info I found on the firmware.

ex1

ex2

What would you suggest I do?

Well, if it was me I’d probably go back and re-read post #5 and follow the instructions there…
But that’s just me.

1 Like

You should not flash your firmware until you understand what that does.

I think the answer above (New user with questions - Laser not turning off between cuts) is a good place to start.

After reviewing that, let us know if you are still having issues using this format:

I installed Lightburn with the intention of using it to print my logo into my products. I loaded up the file expecting it to burn my logo with no issue. I had previously used LaserGRBL and had no issue. Instead the laser stayed turned on in between shapes, creating a connected network of pieces that should not be connected. I believe it is because Lightburn is running the engraver as a CNC machine and not a laser engraver. I am not sure how to tell the software that we are in fact running a laser.

Machine: Sainsmart CNC3-3018Pro
Controller: ??
Firmware: ?? Possibly in pictures above. Otherwise any tips on how I can find out this information?
Lightburn is installed with the latest version.
The issue is new.
Running Windows 10. 64 bit

I am really not trying to make this hard, but did you read this?

That was in a post provided above. :slight_smile:

Please type $$ into the console and hit Enter/Return. This will start to display information just above in the window where it says, “Waiting for connection…”. Copy and paste the entire results here for review.

image

1 Like

I apologize. I overlooked that and wasted yalls time. That was an oversight on my part. I will take care to be more aware and considerate in my future posts.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.