New user with some little issues to get started: Start up and burn size issues

Just newly set up and almost ready to go.

  1. Machine 50*65 2 axis 15 W laser fixed focus and upgraded grbl firmware to 1.1 succesfully.
    When I open LiteBurn and laser connects, the laser turns on full for a few seconds (no XY movemnt)
    How to I prevent this?

  2. Trial burn the text P. Size created to be .5 inches high in work area. Burn result is 1.75 inches high. How do I correct or calibrate the sizing?

  3. The laser burns the inner line of the letter P and when it goes to outer line of the P, the laser does not shut off and creates a diagonal (unwanted) line to go to the outer line. How do I make the laser shut off when transitioning to next line?
    Alex

Very common issues for a system that is not setup correctly. Have a read here to walk you through the process of setting this correctly in both your firmware and LightBurn.

Start here: https://lightburnsoftware.github.io/NewDocs/FirstTimeSetup.html

Thank you.
I fixed the unwanted laser burn between lines.
Now my issue is correct scaling.
12.703 mm high (letter P) on work screen should burn 12.703 mm on the work piece not 3.5 times larger.
How to I set the sizes to be the same on both work screen and work piece.
Then I think I can start practicing some burns to get used to this software… so far I like it.

Read here for step size config: https://github.com/gnea/grbl/wiki/Grbl-v1.1-Configuration#100-101-and-102--xyz-stepsmm

You can also go to Edit > Machine Setting and click ‘Calibrate’ on the bottom, and LightBurn will adjust them for you. You most likely overwrote the settings in the controller when you updated the firmware.

The size of your system is defined in firmware. You then tell LightBurn the size of your system, which will be what you have set in firmware.

$100, $101 and $102 – [X,Y,Z] steps/mm

Grbl needs to know how far each step will take the tool in reality. To calculate steps/mm for an axis of your machine you need to know:

  • The mm traveled per revolution of your stepper motor. This is dependent on your belt drive gears or lead screw pitch.
  • The full steps per revolution of your steppers (typically 200)
  • The microsteps per step of your controller (typically 1, 2, 4, 8, or 16). Tip: Using high microstep values (e.g., 16) can reduce your stepper motor torque, so use the lowest that gives you the desired axis resolution and comfortable running properties.

The steps/mm can then be calculated like this: steps_per_mm = (steps_per_revolution*microsteps)/mm_per_rev

Compute this value for every axis and write these settings to Grbl.

This might be a good friend to have around when playing with these settings:

You can change these firmware settings from the console typing you change in and hitting Enter/Return. LightBurn also provides access and control to these settings from the ‘Edit’→’Machine Settings’ window.

OK Thank you a lot.
I have seemingly resolve #"s 2 & 3 !
Now the software start up and shutdown stationary few seconds full power laser burn issue.

My quick and depending on memory is to power off the laser, start Lightburn then power on laser. Same power off before closing software eliminates that nasty burn twice.

Can this be programmed differently?

LightBurn does not send anything to the laser at all to make it fire unless you run a job, so this means your laser is doing this on its own when connecting.

Do you have any other software to try with? Did the laser come with stock software that does not have this issue?