Laser not turn off between cutting/drawing shapes

Hi,

Ive just downloaded the trial version and made some “burning” tests. I’m very happy with my first results and with the software, but I could not find the solution for turning off the laser between shapes, the laser continues to work at the same power rate.

On my test I tried shapes with different order numbers, with the same order numbers, with different layers, or “Hello” word. But the same result as the attached photo, the laser is not turning off between cutting / drawing shapes.

What I’m doing wrong?

Thank in advance,
Corny

if you are using a grbl controlled machine send a $32=1 command to enter laser mode.

The movement lines don’t turn off because you don’t have laser mode enabled, or possibly because your spindle max setting ($30) doesn’t match the setting in LightBurn 1000 is the default in LightBurn and in GRBL, but some software changes it. You can see your GRBL settings by typing $$ in the console and pressing enter. This is what they all mean:

In the console is showing me this:
$$

$0=10

$1=25

$2=0

$3=5

$4=0

$5=0

$6=0

$10=1

$11=0.010

$12=0.002

$13=0

$20=0

$21=0

$22=0

$23=0

$24=25.000

$25=500.000

$26=250

$27=1.000

$30=1000

$31=0

$32=0

$100=1600.000

$101=1600.000

$102=1600.000

$110=1000.000

$111=1000.000

$112=800.000

$120=30.000

$121=30.000

$122=30.000

$130=200.000

$131=200.000

$132=200.000

ok
__
Now I realised that I can’t setup the Power min % value… But looks like $30 is = 1000

Do you have 1000 set in ‘S-value max’ found on the ‘Device Setting’ page in LightBurn? These need to match in both grbl and LightBurn.

image

I also see that your $32 is set to 0 (zero) which is OFF. Ensure ‘Laser Mode’ is enabled by typing the command:

$32=1

In the console (just above macro buttons) and hitting enter.

First time returned me an error but second time works. Now is stoping between shapes but the problem now is that the laser doesn’t seems to be enough strong to burn…

Yes the S-value max is 1000. Now the Laser mode is enabled and is switching off between shapes, but is not enough strong to burn…

also send an $30=255
$31=0 these send min and max power you may need to adust settings in lightburn to match the 255. or alternatively send an $30=1000, which I think is the default in lightburn.

@hard12find, He has the set $30 set correctly and matching in both LightBurn and his grbl, but thank you.

What type of laser do you have? CO2 or Diode? What are you setting this cut for? Fill, Line, is it an image? What cut settings (power min/max) are you using?

For a GCode controller Min is only used to set the low-power value when grayscale engraving.

For diode systems, you’ll want to set Min to 0 (or very slightly above) and Max to 100, and then vary the speed until you get a good result. Typically for a 2.5w diode would be in the neighborhood of 3000 to 4500 mm/min (50 to 75 mm/sec).

Diode. The typical laser from Ali Express for CNC 3018 :slight_smile:

Before changing $32=1 was burning very nice with 100 mm/s (like in the photo attached)

$33? I am not familiar with this.

$32=1 sorry :slight_smile:

So finally, looks working well like the following:
$30=0
$31=0
$32=1

$30=1000 is setting the laser at the minimum power, not at the maximum power…

Glad you got things sorted. I do have to say I don’t fully understand your response as the official GRBL git-hub site references these settings.

image

What version of grbl is installed on your controller?

1 Like

What might be happening is that you could be commanding the laser to move much faster than it actually can. Your maximum rate settings ($110, $111) are set to 1000 mm/min, which is 16.66 mm/second, or in layman’s terms, slower than molasses flowing uphill in January.

If you tell the software to try to move faster than that, the laser mode you’ve now enabled will reduce the power to compensate for the fact that it isn’t allowed to go as fast as you’ve requested. If you try running a cut at 15mm/sec, with $30 set to 1000 as it should be, you’ll likely see full power.

If you want that full power available at higher speeds, you’ll need to lift that speed restriction in the settings.

2 Likes

I don’t know what version I have, or how can I find that. I’m still learning, I’m a beginner in this :slight_smile:

I saw my max speed is 30. It’s possible to run this at a higher speed? Or is better to leave how it is?

$120=30.000
$121=30.000
$122=30.000

I made more experience yesterday with different variables, and I saw in the case of my wood (plywood) that is better with fast acceleration, more laser power and less counts than many counts with less power. Buts it’s still burning the margins, specially the corners. Making some research in youtube I saw the solution for that is the air compressor.

One more question, when I will go back for spindle carve I need to set up again $32=0 ?

30 mm/min is very slow, so I assume you should be able to go much faster, but that really does depend on the machine you have. With step settings of 1600 steps per mm, your 8-bit controller is going to hit a speed limit that’s relatively low. For example, if you move at 100mm/sec, GRBL would need to send out 160,000 step pulses per second, but the maximum for GRBL is 30,000.
(https://github.com/gnea/grbl/issues/194#issuecomment-301501645)

Working backwards from the 30kHz speed limit, dividing your 1600 steps per mm gives you a maximum speed of 18.75 mm/sec (1125 mm/min). If you can reduce the micro-stepping on your motor drivers, you’d be able to increase that.

Probably, though it depends on whether you use the PWM output to control your spindle or not. If you don’t, it probably doesn’t matter.