Newbie but Old Laser not working

First up Hello from NewZealand, been snooping around for a few days now and it is a bit daunting for a 71 year old man, but hey that’s what you guys and gals are for (wink wink).
Any way got me a Sulpfun S9 a few weeks back and have been having fun, had a couple days off for pen turning and then thought it be a good idea to try engraving a pen. Well set things up and no work. Ok here comes the long winded text trying to explain what’s going on or lack there of. No video sorry working on that but as stated it’s an age thing…
No limit switches, after I turn the machine off I manually set it to home position (my case bottom left (cause the machine is side way’s to the bench).
Went to Frame an image and the machine just did not move, after a lot of head scratching (3 days) thought I better try you people.
I can use the Jog keys to move the Laser to the Left and Right but not Forwards or Backwards (up or down???). I have the Absolute Coordinates set or the Currant Position both do the same thing.
The Laser Fires on/off, when I try to Frame or Start the motors sound like they are struggling to move so I try a light press to help move but they are solid so have to press the Stop Button.
Will/Am going to try to post a picture from the Console window I don’t understand it but I think it’s a Homing thing/problem…

Cheers Merlin…

1 Like

Does this mean the laser head is on the corner of the controller when you turn it on? If so, this is likely the source of your problems.

You need to start the laser with the head positioned in the corner circled in green here:

Jog controls will conform to the orientation in the picture.

When you start the laser, the current position of the head (hopefully in the lower-left corner) will be set to 0,0.

If things don’t work after matching this recheck your connections and make sure they’re properly seated.

1 Like

Thanks for the reply, no my machine as per green circle, all connection look and feel secure.
Funny…after checking everything turned the machine off 30 seconds later turned on and the Laser now does NOT work at all there’s a light glowing in the control box so there is power but flick the switch and not a thing… Oh bugger…

Make sure the correct COM port is selected in the pull-down field between “Devices” button and the Name you gave your laser. It may be listed as “Choose”. This happens if LightBurn is on prior to connection.

If there are no options in the pull-down try right-clicking the Devices button.

1 Like

Thanks again. I’m sure they are all correct but will check again first thing tomorrow morning, going to be away from laser most of the day if I get back home in time to reply this time tomorrow evening.
Here at the bottom of the world it’s 5.45 pm at the moment so…knock of time my back’s killing me…


Hi again just bumping this thread up again, I still have not found a solution to my problem getting frustrated with not being able to use it.
Can anyone think of anything please Wood a new main board solve this problem or is it just a software problem…Cheers Merlin…
I have just tried a LaserGRBL program and it does the same thing cant move forwards or backwards ok with Left and Right…
So makes me think it’s not software if 2 different programs do the same…

Check all the wiring and then reverse the X and Y axis after.

1 Like

You hadn’t provided an update from your previous reply so it wasn’t clear what progress had been made.

Does this mean that you are now able to connect to the laser?

I suggest you take a more systematic approach to troubleshooting. @LaserWillie brings up a workable strategy.

The issue with up-down movement could be one of the following:

  1. software - based on trying this on both laserGRBL and LightBurn this seems unlikely
  2. controller/driver
  3. cable
  4. stepper motor
  5. something mechanical post stepper

I suggest you go through one step at a time to rule out each issue. Let’s take this backwards.

  1. something mechanical post stepper - remove the belts from the Y-stepper so that there’s nothing obstructing the stepper from moving. Try moving up/down to activate the stepper. Can you see the pinion spinning? If yes, then this means the belt wasn’t properly tensioned or the pinion is not secured properly to the stepper. If no, then proceed to next step.
  2. Take the X-axis cable on the motor end and plug into Y-motor - Do left/right jog commands result in movement in the Y-stepper? If yes, then stepper is okay.
  3. Take the Y-axis cable on the motor end and plug into X-motor - Do up/down jog commands result in movement in the X-stepper? If yes, then cable is okay.
  4. If cable and stepper are both good then it’s likely the board/driver on the controller is bad.

Run through these steps and report back on results.

1 Like

Sorry folks Update for berainlb com port ok,
Willy thanks for the suggestion but had already tried that on of the first.
berainlb: Will go and check what you have suggested and report back soon.
Thanks for the replies…


1 Like

Just a quick question, should these two wires for the stepper motors

be wired the same way as per photo… as you can see the 2 wires on the left are different Grey on the outside on one the on the right grey second from the left…

Typically they’re the same but it’s possible these are reversed either in an attempt to reverse direction or possibly because it doesn’t matter in the application. IN either case, the cable should still work in the sense that it will drive the motor. However, the direction may be reversed.

1 Like

Right oh, Motors both work, Reversed the wires in above post no difference, put them back again, got to the motherboard and done a continuous test on each wire and all worked ok, but can’t guarantee if there is full power going though. So that only leaves the Board or the Driver, now the Driver is that the one that is install when setting up (ch340) or something similar.
So I guess I gotta get touch with the supplier another month to wait…Bugger…
Thanks guys for the help…


When I mentioned Driver I was referring to the stepper driver. In the case of the Sculpfun S9 the driver chip is soldered to the main board so it’s not removable.

Let me get some clarifications on your findings.

How did you verify this?

What do you mean by no difference?

When you say “all worked ok” what are you referring to specifically since from context I’m gathering that there’s still a problem.

It’s helpful if you could respond line-by-line to the specific test conditions so that it’s easier to understand the findings. Otherwise we’re both having to continuously shift frame-of-reference.

Sorry …try to clearer:
both stepper motors work, The wires to the x axis are ok because the motor works but the y axis don’t so I reversed the wires on both x and y now the y axis works but the x does not, so that means both steppers are working.
When I checked each wire in the y axis loom (all 4) with a multi meter for continuously (meaning power at both ends) all 4 wires are good, so that being said steppers and wires all good.
Leaving I believe Motherboard/Driver???.
Sorry I think I have explained that the best I could, not being very good with electronics…


Thanks. I think I’m following now.

Swap the wires on the controller side and retest. What is the result? If X stepper moves and Y stepper does not, then Y cable is bad (or miswired since you tested for continuity). If the reverse then likely something at the board.

If you find that the wire is bad then try relocating the pin leads to match the working cable.

berainlb: Thanks for the patience…I’m up and running again.
Rich from LAHobbyGuy had the answer (In the console tab, type in $X and press Enter to unlock.
Then type $RST=* and press Enter to reset.).
Tried the switching wires had some wire looms from an old rebuild laser from a few years back and tried that but nothing, so again thanks and to Willy…

Cheers for now


Glad you’re back in business.

You’re saying that was the fix for not being able to move Y-axis?

Did you happen to grab a copy of your machine settings or output from $$ before resetting your configuration? I find the fix unusual for the symptoms.

You were never in lock state from what you described and you hadn’t indicated anything that would imply a GRBL configuration change. It’s also only recently that I learned that newer versions of the Sculpfun would allow for GRBL configuration changes so I suppose that’s now a possibility.

Could you run these commands in Console and return the results:


Also, if you have your machine settings or output from $$ from earlier that would be ideal.

Sorry for the long delay Health issues… Anyway The only pictures of before are during (all attached)
Cheers Merlin…

This when L/B starts up before:

And the two that you requested ???

No worries. Hope you’re taking care of yourself.

I don’t see anything really of note in the config which is what I would expect at this point. I would have been very curious to see the configuration from before the reset.

Are you still getting the Homing error:5? If so, disable “Auto-home on start” in Device Settings.


changed the setting for Auto Homing just in case, An another Q on the Console can/is there away of saving the command’s if there is a problem that the Command’s can be saved to a TXT file like notepad or similar…