Newer than new ... newbie

So many questions where do i start. I have a cu.usbserial-1420 and GRBL-M3 (1.1e or earlier) Hopefully you know what that means cuz i have no clue. Q1. How do I set up the burn work space. 2. my laser is either on all the time and continuously burning or I have to turn of the switch on top. So it’s making lines between where it is supposed to turn itself off. 3. I don’t know how to set the burn strength button. Either it’s too much and all it does is keep burning and I have a big mess or it’s not strong enough to do anything. 4. I hear people talking about the settings to be burn or engrave but I have line, fill or line & fill. Which is engrave and which is cut? 5. What is the difference between Gcode and CNC. I only have the Gcode come up when I connect my laser to the software. Should I have additional software that works with the Gcode? 6. Can I use a png file as opposed to jpeg or svg? Okay. Hopefully someone can help me get this thing up and running.

1 Like

Hi Josie - welcome!

Diving right in:

cu.usbserial is is just the identifier for the port on your Mac that the laser is plugged in to. If you can take a picture of what you have, that would help us identify it. Post a picture of the machine itself, and one of the circuit board on it that you plug all the stuff into, so we can try to figure out what it is. When you first connect to it in LightBurn you should see something like, “Grbl 1.1e ($i for help)” - copy and paste that text too.

Q1: I’m not sure exactly what you mean by the burn workspace, but when we use that term we mean the size of the working area of your machine, and you set that by going to the Edit menu and choosing Device Settings. In the upper-left of that window you can set the size.

Q2: If the laser is on all the time, there’s likely a setting wrong, but usually the GRBL-M3 device takes care of this. We’ll wait until you’ve posted the info above about the machine and we can go from there.

Q3: - - same as Q2 for now.

Q4: Engrave and burn are a little bit muddled as terms go, and can mean different things. Engrave generally means marking, but not cutting through. You can engrave along the outline of a shape, which I call ‘Vector Marking’, or you can scan back and forth across the shape, filling it in, and I call that ‘Vector Engraving’. Image Engraving is the same thing, just using as image as the source. Cutting would be identical to Vector Marking, just going slower and using more power.

In LightBurn, “Line” just means following a line with the laser, and will either mark the surface, or cut through, depending on the power and speed you use. “Fill” is scanning back and forth across the shape, with the laser on.

Q5: CNC is a blanket term that means “computer numerical control”, or basically any computer controlled tool. A computer driven laser machine is a CNC, and so is a computer controlled woodworking router, metal cutting machine, and so on. Hobbyists often mean a 3-axis woodworking machine when they say CNC, but it’s kind of like saying “rock” instead of quartz, granite, slate, etc.

GCode is a common language used to talk to CNC machines. Not all machines use GCode, but many do. It’s a set of instructions like this:

G0 X0 Y0   ; quickly go to coordinate XY 0,0
G1 X10 Y0  ; perform a cutting move to XY 10,0

(I glossed over a lot there, but that’s the basics)

Q6: Yes, you can use png, jpg, svg, bmp, ai, dxf, and a couple others in LightBurn. Png and jpg are image formats, and svg, ai, and dxf are primarily vector graphics formats, but can also store images.

Yes, it said Grbl M3 (1.1e or earlier)

Sorry this is blurry. I did a couple of short videos showing this because the machine is at a friends house right now. This is above the laser. I’m pointing to the button that increases power to the laser. Problem is if I turn it down so it’s not continuously burning it doesn’t do anything. If I turn the power up then it doesn’t turn off where it is supposed.

When you’re at the laser next, type $$ in the console in LightBurn, and press enter. Copy and paste the output here so we can check the settings.

Check in Edit > Device Settings to for the S-value Max setting. Older versions of GRBL use 255 as that maximum, I think - it’s either 1000 or 255, but I can’t recall which. I know versions 0.9 and older use 255, and 1.1e and newer use 1000, but I’m not certain of the ones in between.

Having said that, if the laser is still firing using the GRBL-M3 mode in LightBurn, there might be a wiring issue. Did it come with other software, or have you tried it with anything else?

Yes, they sent other software, however it’s all Microsoft and I have a Mac. It’s worthless, and so are they when it comes to getting help. Did that video help? I will take another one today when I go over there and do the video of the results of the $$.

Also, I got the plugin for Inkscape to convert images to Gcode. Don’t know if that matters or not.

Do I need to have my computer online? Did I mention it’s 15000mw? Don’t know if that matters in all of this? Also, was able to get the software LaserWeb to work but… not as good as lightburn.

So far there are only images posted here, not video. Can you show a pic of what you chose for the device in LightBurn? (It should be GRBL-M3) The other things I mentioned (the $$ settings) will be the next step before I can help much.

Okay, finally back at the machine. Here is the code.
Grbl 1.0b [’$’ for help]


$0=10 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=0 (dir port invert mask:00000000)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.010 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$30=1000. (rpm max)
$31=0. (rpm min)
$32=0 (motor lock bool)
$33=7 (motor mode mask:00000111)
$100=80.000 (x, step/mm)
$101=80.000 (y, step/mm)
$102=80.000 (z, step/mm)
$110=10000.000 (x max rate, mm/min)
$111=10000.000 (y max rate, mm/min)
$112=10000.000 (z max rate, mm/min)
$120=250.000 (x accel, mm/sec^2)
$121=250.000 (y accel, mm/sec^2)
$122=250.000 (z accel, mm/sec^2)
$130=500.000 (x max travel, mm)
$131=500.000 (y max travel, mm)
$132=500.000 (z max travel, mm)

The next thing to check is in Edit > Device Settings, on the right, near the bottom. Make sure S-Value Max is set to 1000, because that’s what is set in your firmware for the “RPM max” setting ($30) and they have to match.

If you do that, and you set up the machine as “GRBL-M3” in LightBurn, it should work ok.

I will say that anything prior to GRBL version 1.1f is going to be bad at doing pictures, and engraving will end up with dark spots, because there is no way to tell the machine to move continuously when the power changes. It thinks there is a rotating cutting tool mounted, and that it needs to pause every time you change the “RPM” setting (which is the same value used to set the laser power).

GRBL 1.1f and later have a mode called Laser Mode that sorts out a lot of issues.

So do I need to replace a part or how can I get the GRBL 1.1f?

I would say for now, walk before you try to run. Upgrading the firmware is just flashing new control software onto the same board, but it will reset settings (so you’d need to write down the settings you have, or save them so you can put them back).

I also don’t know yet exactly what board you have, and therefore I’m not certain how easy or hard it would be to do that update, and I haven’t ever done it from a Mac. It’s probably not terribly hard, but given that you’ve said you’re very new to all of this, it’s probably better to hold off until you’re more comfortable with how the stuff works.

Piling too many brand new things on all at once is a good way to make things harder on yourself. :slight_smile:

How do we determine what board I have. These are the photos of the device. I have checked all wires and everything is the way it should be.

Did I mention this is a Universal Engraver 15000mw blue CNC. Don’t know if that makes any difference or not.

The board that says ‘GRBL CNC Controller’ on it is the brain - that’s your controller. It looks very similar to the controllers used on Eleksmaker laser machines, so the process for upgrading the firmware on those might work here too, but I’ve never done it myself, so I can’t walk you through it.

I know I am absolutely clueless when it comes to coding. I’m not that savvy. Do we need to do a video chat for you to walk me through this and me at the machine? I am so lost. Why do they make these so difficult?

Hi Josie,

As Oz mentions, that control board is one of many generic designs out there, and not one that we specifically recognize.

There are some resources that may help, but there may also be some nuance to your specific one, so the only way to really do it is to try it and figure out on the go.

Our support team is happy to continue to help out via written communication here on the forum, but this particular topic of “how do I flash my specific controller to the latest grbl” may be getting a bit outside the realm of software support. Hopefully some of our users may be able to help, as a number of them have done this before.

I am absolutely clueless when it comes to code. The best I can do is cut & paste. I have contacted this company Universal Engraver and they are the worst! I cannot get help from them. Obviously I paid too much for a piece of junk that doesn’t work. The lightburn software is excellent and easy to use. I tried using their LaserWeb software but cannot understand it at all. So thanks LightBurn and the forum.

1 Like

So finally found Xloader for Mac, Downloaded Arduino and in the files from the company I have this hex code
grbl_v1.1h.20190825 (1).hex. I suppose this is the source of all my problems, now how do I get it into the LightBurn?

To help, the concepts you are talking about are for your controller and not LightBurn. The term commonly used for updating the firmware running on your controller is ’ to Flash’. So you are talking about “flashing” your controller firmware to the latest opensource GRBL.

But I also point to what @raykholo said above.

Once sucessful, we can help you get LightBurn configured correctly.