No connection with the new version

Hello,
Yesterday i downloaded the new version 9.00 Today i cannot connect to my Arduino Mega 2560 anymore.
Are more people having this problem?
The software say: Port opened, waiting for response. If i give a command it says Starting stream, but nothing happening?

Version 0.9.01 was released immediately after to fix a serial communication issue on some systems. Do you have 0.9.00 or 0.9.01?

I have 0.9.01
In the mean time i discover that i can connect to the laser by creating a new machine.

If i create a new lasermachine that it will connect to it. But if i close the program and start it again it will not connect anymore. I have to create a new lasermachine again.

I have found the same behavior with a miniGerbil board. It will find it and create the device using the wizard, but will not connect to it in the console.

I’m fairly sure I understand why this is happening, and it boils down to Arduino devices using a pin to tell the machine to reset that is supposed to be used to tel the machine that your computer is connected to it. Smoothieware devices (and some others) require this pin to be ON, where it looks like Arduino devices require it to be OFF. I’ll come up with something that works quickly.

2 Likes

Just going to mention that on startup the Laser menu "home " is default
’ thats why i get homing error…

It’s the default because most dedicated laser systems have it enabled. I’ve added code to the auto-finder to figure out if you have homing enabled and turn off that default if you don’t.

1 Like

I’m having this same issue. I’m using a SainSmart DIY CNC with a 5.5W laser module running grbl 1.1f. Lightburn recognizes the device, but won’t connect.

Thank you. At work now. Will test tonight.

I tested the new version but it is not working. Only by creating a new device will contact to he laser.
The program blocks after sending a (home) command or jogging the laser.

Foutmelding%20in%20connectie%203

I’ll have to try a Marlin setup as well. Is your baud rate correct? (and was this working for you in a previous version?)

It was working in version 8.07 very well. The problem started after the update to 9.0
Than i tryed 9.01 but that was also not working. I did not change the baudrate. Do i have to?

No, probably not. I made a change to the low level comm driver, but it appears that some DIY style boards do not like it. What kind of board do you have? Is it Atmel based?

It is a Arduino Mega 2560 with a RAMPS 1.4

I have an Arduino Mega 2560 with Marlin 1.1.9 connecting correctly.

You said, “only by creating a new device will connect to the laser” - what do you mean by that? (if you created a new device, you’d probably have to change the baud rate, as the default for Marlin is 250,000, but the default for serial connections in LightBurn is 115,200). You would change that in the device settings, here:
image

Testing this morning. It look that the new value of the baudrate not wil be saved. If i change the value and save it and look again to the settings than it is back to 115.000
Maybe that is the problem?

Loaded and did a quick test. It recognizes the laser now and I have proper motion control. Loaded a quick picture and I do see the laser flashing. However, I did not take time to set the laser parameters so there was no burn. I will do a proper test tonight.

I have look’t to the pref’s file and see that the value for baudrate is 0 Is dat correct ?

I change it to 250.000 and saved the file. When i start LB again it will override to 0 again.