No laser at boundery scan

GRBL will turn off the laser at fast (rapid) movment (G0) but lightburn send a G0 at the begin of the boundery check. And boundery check without a laser is useless.

BR
Hexxter

Boundary check without a laser is safe. Your machine type, listed as “custom” in your profile doesn’t tell me whether you have a CO2 system or a diode laser, but I’m going to guess a diode.

This question gets asked very often, so we have it as a FAQ entry:
image

Read here:

Yes its a diode laser NEJE Master 20Watt.
I have the start a fire button and i can enable the beam (low power).
But after start the boundary test it is disable. I see in the code
lightbeam send an g0 move to the laser maschine. And this disable the
beam (docu grbl)

Which version of LightBurn are you running? 0.9.12 and up should leave the beam enabled when jogging if you have the Fire button enabled.

Version 0.9.14 grbl Version 1.1f (2017). I use §32=1 (lasermode) with max val 1000 on grbl and in lightburn. If i use the fire button and it works, but when i klick on the boundery check the beam goes off.

The GRBL docu shows:

The laser will only turn on when Grbl is in a G1, G2, or G3 motion mode.

In other words, a G0 rapid motion mode or G38.x probe cycle will never turn on and always disable the laser, but will still update the running modal state. When changed to a G1 G2 G3 modal state, Grbl will immediately enable the laser based on the current running state.

Please remember that G0 is the default motion mode upon power up and reset. You will need to alter it to G1, G2, or G3 if you want to manually turn on your laser. This is strictly a safety measure.

You can stop advising me on what G0 does - I’m quite aware of how it works. The problem is that, by default, LightBurn does everything it can to turn the beam off when not running a job, because most of our users have CO2 systems with invisible beams, and randomly leaving the beam on could blind someone.

If you read the link I sent, it tells you to click on the Frame button while holding the Shift key to turn the beam on when framing.

Shown below:

ok Shift key solution is working. Thank you

But i have a second problem. Sometime the laser makes burn marks on empty areas.
Its random not always the same…

I hope you can see the small marks on the W. But its not only on the w in saw ii is on the star or other latters too.

BR

That looks like you have enabled ‘Smoothie Clustering’ and don’t have cluster firmware installed. Did you start with a Smoothieware device and then change it to GRBL, perhaps? The only other thing I can think of that would cause that is electrical interference on the connection to the laser.

You should also enable ‘overscanning’, so you don’t get the dark edges on the sides of the letters.

sorry i doesnt find the smoothie clustering option. Where is this option in the application.

BR

You won’t find the option in the GRBL profile, but if you started with Smoothieware, played with a bunch of settings and enabled clustering in a Smoothieware profile, then changed it to GRBL, that setting might still be applied.