No Movements on Y-Axis

Seeing as the manufacturer won’t process my question, I’ll ask it here since the issue is in Lightburn. I have an NeJe Master 2S Plus Diode Laser and with a replacement control board installed I can finally get Lightburn to talk to my machine, almost. Just about everything works except -Y-axis movements. If I hit the right arrow key or click on it the laser head moves the right. If I click on the down arrow key, nothing happens. If I click on the Home key, the machine moves to the Home position.
I have the origin set to the Left Rear, so should I change it to the Left Front position. I just realized that Home and Origin are two different things and is that why the machine won’t move as per directed?

If it 'home’s successfully both axes are working.

Did you change where it homes from the previous control board?

Watched a guy put one together on a video and it was front right at the time but didn’t actually see it powered up. After a few videos I gave up. I would think where ever it goes on power up is home. Is that not where you checked the box in your device configuration?

Good luck :slight_smile:

I used the tutorial from Lightburn Setup for the Neje Master 2 (Original, Non-Homing) — North Lakes Woodwork to setup my laser. I’m hoping that by changing the origin that it will work correctly.

Check this out on Coordinates.

Where do you put the head, when you power it on?

That is 0, 0 for the machine. The question is when you tell it to move the X axes +5mm does it go right or left? I assume you are setting it to a corner. You can set it to the center of the table and see if lightburn will let you jog correctly. Set the ‘distance’ and ‘speed’ low… Might tip you off as to what’s going on.

If you still get no Y movement, maybe you have a hardware issue.

Someone out there has this laser and can probably help you more, as I’ll probably just confuse you since I don’t know your hardware.

Good luck… :slight_smile:

When I turn my machine on and Home it. It travels to the X and Y Home Switches. Home is to the top left. I would prefer my origin to be in the center of my workspace. When I home everything is as it should be and if I click on X+ the module moves to the right. After homing, and I click on the down arrow of Lightburn, I am not getting any movement. I’m pretty sure it is a setting in GRBL that is off, it’s just Which One. The control board is a new replacement board as my previous one was faulty. At the moment I am just trying to get it moving so that I can do a Speed and Power Calibration.If it gives me much more hassle then it has for the past month, I am going to replace the entire electronics with a known working GRBL 1.1h board, motors and limit switches. I was hoping that someone here had finally figured this system out and would share their settings.

Don’t do anything as rash as a new controller. If the X and Y axes move, then they are working. Why lightburn isn’t controlling it is a problem.

Did you click on the up arrow to see if there was a response?
After you click the down arrow, will it still respond to right click, without a reset?
What is the “distance” and “Speed” set to in the move window?
Did it generate any kind of grbl error in the ‘Console’ (Cuts/Layer → Console) of lightburn?
How does it compare with the original controller configuration? You did make a backup of the working configuration didn’t you?
If not, do you have the original controller you can copy it from?

If you do a replacement, you will be back to square one and everything you have done, wasted. It’s partially working. Give it and us a chance to help you get it operational. If it’s configuration, nothing will be different, except a lighter wallet. :slight_smile:

1 Like

Hi Ronald, Have you checked your settings to make sure ‘rotary’ is disabled?
Was watching another thread where someone was having a lot of problem with axis movement, turned out to be the rotary was still selected. :crossed_fingers:

Chris is talking about this link, with screenshot to help… :slight_smile:

That’s the one :grin:

I’ve tried just about everything that has been offered from the North Lakes Blog for the NeJe Master 2S Plus to manually editing the GRBL Settings. It’ll work one minute and fail the next. And that is with the replacement control board the manufacturer sent. I’m about to rip it all apart and modify it with a Sainsmart GRBl 1.1h Board that I have on hand. I didn’t have this much problem with my OpenBuilds BlackBox Controller which also uses GRBL for my CNC Router. If I could find some assistance somewhere I’d even be willing to dive into converting everything over to Marlin 2.0 after diving head first into Visual Studio Code. If I can reflash the firmware for my Ender 3 and the SKR Mini E3 v1.2, then I should be able to create a firmware that works with this laser and even turn on Auto Limits with TMC 2209 Drivers.

It doesn’t work that way. If you have it configured properly it will do the same thing over and over. If that were not the case, CNC would not exist. Unless you payed extra for the poltergeist option, I doubt it’s been properly set up with all the parts.

Did you tray any of these? It might actully help us help you.

Don’t ask me how I did it, but I finally got my machine to talk to the Lightburn Software. I tried updating through NeJe using the 2,000,000 Baud Rate and everything worked perfectly after that. Why that worked over the 932,000 Baud Rate is anybody’s guess.

Glad you’re up :slight_smile:

Take care, have fun…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.