Not Completing Corner Cuts

After importing an svg. file, I checked the preview and it looked fine but when I went to cut, corners were missing. I’m using a GRBL Wizmaker (new, Chinese brand) laser that’s cut other designs fine. I reviewed all the other forum questions related to my problem and none of their resolutions helped.

I tried:
Tabs/Bridges Off
Cut on both light and dark materials
Used at Very Slow Speeds (the Wizmaker tends to run much faster than my other lasers)
Cutting in Beginner Mode


Any help would be greatly appreciated!

Can you upload the .lbrn file for review?

It looks like you’re either very out of focus or there’s something going on with the design.

Made some adjustments to the laser focus and tried cuts with other svg. files and I still have the same problem unfortunately.

Thanks for taking a look!

trace.lbrn2 (197.1 KB)

I don’t see anything fundamentally wrong in the design.

Is the photo above the front or back side of the burned material?

The burn line looks extremely wide. This is why I was speculating it being out of focus? What happens if you burn a simple horizontal or vertical line?

You may want to try running a ramp test to confirm that your focus is acting normally. There may be something else going on.

This is the front. The cut is actually very small so I had to zoom in and that’s probably why the burn marks look so wide. Thanks for suggesting the ramp test. It helped me confirm that my focus has been fine and I was able to cut lines and simple shapes with no problems. So, I’m still not sure what the issue is. Yesterday I downloaded a free svg. design that had the same level of intricacy as mine and I had the same problems with a few lines not connecting all the way. If my goal was just to utilize paper it’d be fine but this design is for mother of pearl sheets that are very fragile so I risk damaging them if I have to pull them apart.

It’s possible that there’s a firmware bug. Can you try disabling Constant Power Mode to see if that affects the result?

Gave that a try and unfortunately didn’t see a difference. One variable I’ve kind of become suspicious of is how fast this laser is. I mentioned in my initial post that, that’s why I have the speed set so very very low. The travel time between cuts is very fast as well which may be the culprit but when I went into the Machine Settings to change the X,Y, Z (and then even tried A) settings for travel speed, I saw no difference. I also tried changing the Fast Whitespace Scan and didn’t see a difference (with a high or low number).

Do you know if there’s something I’m missing?

Thanks for your help!

Have you played with any of the other machine settings?

Traversal moves will move at the speed of one of either two things:

  1. max travel speed of machine based on $110-112
  2. speed set with fast whitespace scan

Typically lack of corner cutting is due to the controller modulating power down with variable power to account for the deceleration required to make the corner. However, constant power mode should negate that entirely. However, it’s common for constant power mode to be broken on some firmware.

Does the laser turn off completely during corners or just reduce in intensity?

Can you share your GRBL settings. Run $$ in Console and then return output. Perhaps something there that’s obvious.

I did try adjusting $110, $111, $112 and then adjusting the Fast Whitespace independently to see if it’ll give me different results but I got more of the same. Toggling Constant Power Mode doesn’t seem to make a difference and it does look like, from at least what I can see, the laser is staying on the entire time. I took video but it looks like it’s too big to upload.

Do I see that speed setting as inches per second? Is that intentional?

Video can’t be hosted directly on the site. It must be hosted externally and linked here.

In this case, are you able to increase power or decrease speed to avoid the issue?

As PY says, your speeds are set to Inches/minute, which is unusual for diodes, and why you’re having to use such small numbers.

Something you can try is using a little bit of Overcut in the advanced tab. This will tell the laser to keep going around the shape after it’s done, and will compensate for a laser that starts late or shuts off too early. A mm or two should be enough.

Thanks, I switched over to mm in my Preferences and tried Overcut with 1mm and still got the same results. I’ll continue vacillating between altering whitespace speed, Overcut, Overall speed & Power to see if there’s a sweet spot somewhere. Will be back by the end of the week if I can’t figure anything out.

1 Like

I’ve been going back and forth with the manufacturer (Wizmaker) about the possibility that it’s the hardware. They’ve been pretty responsive but sent a video saying the lines were not connected in Lightburn after Ungrouping them lol. It kind of made me suspicious that maybe it is the laser. I just wanted to see if anyone was willing to test out the file for me on their laser to see if it’s just me?

I would really appreciate it :face_holding_back_tears: :pray:t4:

Corel Draw trace

Yes, this SVG file has many lines that are disconnected. While this may produce in an odd pattern and not fully optimized, the file should run without issue in ‘Line’ mode. If you are wanting to ‘Fill’ some of these shapes, work will be required to close the desired shapes targeted to be filled. :slight_smile:

1 Like

While some lines are disconnected it doesn’t explain the incomplete cuts. If the vendor is not offering to support I’d suggest returning the laser if it’s still within the return window.

Curious, if you run a circle test does the burn complete? Do you have issues with other materials or just this one?


While they’re “not connected” in the sense that the lines are not joined into a continuous curve, the ends match up pretty well:

That’s a 60 W CO₂ laser at 400 mm/s & 15% power into posterboard. The dense shapes in the center bottom got overcooked because the machine can’t get up to a decent speed with all those teeny lines, but I don’t see any gaps anywhere.

Absent a peculiar setting (which seems ruled out earlier), the hole isn’t in the software end of the boat.


Oh wow! Thanks everyone for the feedback! :heartbeat: This looks exactly like how I would like to cut it! Could I ask what your other settings are (did you use Overcut or Constant Power Mode)?


Just imported the SVG, ungrouped it so I could select that part, told the layer to cut lines fast & light, and away it went.

1 Like

What value are you using for “curve tolerance”?

1 Like