Not enough extend space mid job

Anyone know why. a job would start printing, do the whole engrave once, but then on the second pass, half way through stop, as a result of not enough extend space?

I had updated to the latest version before I ran this print, ran many times before without issue - so couldn’t understand why now. But sorted now with different version of lightburn

Can you print the error codes here? That can help others figure out the issue.

This is always good…

Looked at the machine, very nice…

I could see the Lightburn option to save the RD file, assume a dsp controller…

Are they separate runs? Usually a dsp controller sees a problem like that before it tries to execute.

Are you using ‘send’ or ‘start’?


1 Like

Hi. It simply says Not enough extend space on the ruida controller display.
I’ve run the file many times without issue, but today is doing this

Ha - thanks Jack, I like the laser a lot.

Its actually a ruida controller, and it will I have the fill set to two passes. Im doping everything from the lightburn on my Mac - not touching the controller, pressing send first, then frame and then start

Although, I have tried it again just now with a single pass, and it does exactly the same :frowning: Just stope, with the error, not enough extend space

Excuse the4 fact I cut before I engraved on this one - forgot to move the line down the layers!

I updated to the latest v of lightburn, im going to try an earlier version…see if that makes a difference

Might give it a shot with ‘send’ then run it from the machine console.

You should be able to test it without lasing.


If it’s resolved, you can mark it solved…

However if the problem was solved by rolling Lightburn back to a previous version you need to send a note to support and advise them. They need to know about these kind of issues.


1 Like

how so you mark it solved?
im using VoiceOver to read the content of the screen, because of my low vision, but cant find any solved icon. Have sent a note to support anyway

1 Like

Does your job include Z movement? Also, which version were you using when this happened (before you reverted to an earlier version)? You said latest version. Did you mean 1.0.04?

There was an issue with Z moves during a job that was looked into in March. (this is why I asked about if you had any Z moves).

Do you have a 6442 or 6445 Ruida? Which firmware version are you running on your controller? I have a 6445 Ruida. Is this file one that you would not mind posting on this message (or sending to me personally)? If so, I can test it on my machine to see if I have the same outcome.

Please don’t delete posts like this when it appears to be a bug. If the problem is “solved” by reverting to a previous version, it’s not really solved and we should know about it.

How are you connecting the laser to the Mac? I’m assuming. USB cable?

Hey Ric
Rolling back was only a temp fix apparently - it worked fine twice, then not again.

Testing some files, it would appear there is some packet loss between sending from my Mac and being received at the laser. Making very strange cut lines etc, and therefore ruining a lot of work.

So, a chap from where I got my laser from is trying to look into this, and checking compatibility with Mac IOS etc. And yes, and yes cable USB cable, connected to an Apple USB - C adaptor. I think he will be asking within the lightburn community

MacOS has always been hit & miss with USB connections. I highly recommend getting the $30 Ethernet cable adapter from Apple and plugging a network cable directly between the computer and laser, or computer to router / router to laser. Ethernet does not have the USB packet drop issues.

Cheers Oz. Will give that a go. I have an ethernet cable, but not the adaptor, so ill order one, and see how that goes. Again, thanks for your help

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.