Not recognizing or utilizing total work area

I just purchased Lightburn for my LaserAxe 35x50mm unit, was running T2Laser with it before and updated to 1.1f for the firmware to use that. I’m having an issue with homing the unit but I just read this post, Work Coordinate Offset so I"m going to try that, my other issue is it doesn’t matter where I place an object (I’ve placed it in dead center of the grid) and then hit frame, the laser moves barely 2 inches and now where close to where the image has been placed on the screen.

Try using “Absolute Coords” mode, and read about the other modes here:

35x50mm IS barely two inches.

Should you be defining 350x500mm?

yes sorry, fat fingered that. It is set to 350x500

Set unit to use absolute coordinates and still not working. I’ve set home placed a object in the center of the grid and the laser moves up and to the right hitting against the rails, swapped orientation of the unit in the settings from back right to back left and it does the same thing. And even before I start I hit get position and it shows all 0s as expected but after it moves and I click on Move to position it ends up zero’d on the Y but X is about 1/3 away across my work area. And even after that it reads all zeros again if I click on get position.

LightBurn assumes all systems use positive workspace coordinates. Unfortunately, many builds of GRBL use negative workspace, which is a bizarre holdover from the CNC world. I plan to support this, but haven’t had a chance (or a machine) to do this yet.

The reason your machine moves up / right and hits the rails is that your machine origin is in the rear-right, and your system is using negative workspace.

You can fix that with a workspace offset, as described here:

This moves your origin from the rear-right to the front-left, and makes the workspace area positive numbers instead of negative.

I’m going to swap the unit around again and try setting it to the rear right. I had it setup that way with the other software except I could home the unit to where ever I wanted and afterwards when I hit home it would go back there. The way my setup is and the enclosure, it’s better for me to have the back of the unit closer to me to have access to the controller board.

It doesn’t matter to the software which corner 0,0 is in, as long as +X and +Y move from that corner into the work space. If you need negative numbers to get into the work area it won’t work, and you’ll need to use a workspace offset.