Nova 35 will not make connection with my computer

just purchased a Nova 35, once machine was ready to go proceeded to install software and try to make the connection but i cannot seem to connect. i have tried via USB and ethernet with no luck. i have also tried marking the nova as safe on my Norton software and also disabled it for a bit to see if that worked. no luck. i tried installing the driver as recommended on this site and also with the RD works link that came with the machine with no luck. (it does not connect in RD works either) i do have a router and have tried plugging the ethernet into the router and also directly into the laser both with no luck either. the first 3 groups of #'s in my IP address are the same for both my computer and the laser.

not sure what else to try? any suggestions?

I going to start with the assumption that your computer with LightBurn is connected to your home router by wifi or ethernet and your laser is connected by ethernet cable to one of the LAN ports on your home network router.

It sounds like you have already been following our instructions on Connecting via Ethernet to Ruida Controllers.

What settings do you have here at your Ruida control panel for IP address, and do you see “Lan ON”?


If you see Lan ON and your PC is also on the home network, then test your ability to contact the laser over the network from your computer by pinging it. Open a windows command prompt (Windows logo key +R, type in cmd, and enter) type in ping and then your laser’s IP address, and you should get a “reply” e.g.

Yes computer is connected via wifi, and ethernet cable is connected to computer and then to a port in the ASUS router. I have also tried connecting the ethernet direct from computer to laser and also via USB cord direct from computer to laser.

Ip address on laser is, Lan is ON

Did the ping and I did get a reply, see below. This is with the ethernet cable plugged into the ASUS router.


Do a screen shot and drop the resultant image on the reply window…

By the time I make it big enough to read, the it’s too pixelated to make out what’s there …

Sometimes it’s better with text to use the ‘preformatted text’ iconpreformatted-tetxt
and paste it in there.

The ‘Lan-on’ indicator in the Ruida console only means the hardware is connected …

Did you manually add your machine to the devices? It will ask for the IP address.

If you can see it on the network then it’s responding and you should be able to use Lightburn.

Keep in mind the Ruida has a static IP, so doesn’t query your router for an ip when it signs on the network… The router may issue that ip to another device…


not sure if you can see it now? it IS connecting when i ping it.

yes i manually added the machine


Pinging with 32 bytes of data:
Reply from bytes=32 time<1ms TTL=128
Reply from bytes=32 time<1ms TTL=128
Reply from bytes=32 time<1ms TTL=128
Reply from bytes=32 time<1ms TTL=128

Ping statistics for
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

It’s connected… so lets look at Lightburn…

Using Ethernet is a better option as it’s dependable and there are no ‘drivers’ to mess with…

After you configured it, using the proper IP, it will show ‘Ready’ or ‘Disconnected’ above the laser window…

If it’s ‘Disconnected’ then right click on the devices button and Lightburn will attempt a reconnect.


it says disconnected. i have tried right clicking and it still wont connect. i have also tried deleting it and adding it again with no luck.

on the bottom it says no device found

We know your computer can see the device, so something between there and Lightburn appears to be interfering.

Can you manually configure your anti-virus software to ignore the lasers IP? Or worst case, disable it for a test…

I have Linux, but a great number of us use Ethernet. So I’d say it’s local to your computer.


Thank you for all your help!

yesterday i tried adding the IP address to the Device trust section in Norton and i have also tried shutting it all off with no luck with either.

Since you can ping it, it is available to your machine…

That would indicate it’s between your Ethernet (which is working) and Lightburn…

That points to your computer OS blocking or interfering, if you follow my logic…

Not being a Windows person I don’t know if I can help much more of where to go and look… It appears that something on your machine is blocking access… So I don’t know where to look…

Maybe @JohnJohn can clue you into something that can pinpoint the issue … hang tight… :face_with_spiral_eyes:


o.k Thanks for all your help

Might search around the Internet to find if you have something running that could interfere or if maybe the anti-virus is really turned off…

Ethernet is very dependable and consistent across most platforms…

Good luck


thanks for you help, ill keep searching

Did you install the FTDI driver at the end of the LightBurn install? If not, that’s the most likely reason that USB didn’t work. Ethernet is good, but over WIFI is not recommended.

i restarted my computer and it all works now…uhh…maybe Norton needed a restart to accept the settings. :woozy_face:


I think they are using Ethernet… ?


Turn the laser machine completely off, and then ping again - if you still get a reply that would suggest that another device on the network is using the same address, which would explain the problems.

If this happens for you ping and if there is no reply use that address instead for the laser and in the device settings in LightBurn (often the default IP pool range that DHCP uses for goes only up to 149 or 199 so a number in the 210-240 range is less likely to conflict with other devices).

Nicholas, what you’re suggesting is exactly what happened to me and how I solved it. My router assigned my lasers IP address to another device while it was off. I thought I was pinging my laser but instead a Wi-Fi smart switch was answering.