OFFSET ORIGIN Problem 60W CO2 Laser

Hello, i have an Artsign JSM 40 Chinese laser engraver that i purchased second hand. It works well but i am struggling with origin. When working in lightburn, the machine thinks that it is in position somewhere in the 300’s (inches, 10,000’s mm). Is there a way to reset the origin in the machine? I am using a cloudray controller.


For a big CO₂ laser, switch to Start From: Absolute Coordinates (in the Laser window on the right) so the LightBurn layout matches the machine platform:

I generally turn on Cut Selected Objects (also in the Laser window), move a selected pattern to a convenient spot, and Fire The Laser.

A camera makes that even more convenient. :grin:

These numbers look like it’s failing to home and therefore failing to boot.

If you watch the controllers console does it give you any errors during the boot sequence?

:smile_cat:

Good catch!

That’s the first thing to fix, because until it homes correctly, nothing else will work right.

No i have not noticed any errors when it is booting.

If i use absolute coordinates, the machine thinks that it is at 394, 394. where i am wanting to draw is not even close to this so the machine goes way off window.

Then, as we discovered above, it’s not homing correctly (or at all) when you turn it on.

Upload screenshots of the Edit → Machine Settings → Vendor Settings for the X and Y axes so we can start from the basics.


See attached for vendor settings for X and Y axis.

Both of which have homing turned on, so the question is what happens when it starts.

Does the machine have home switches? It looks like a K-40 style laser, so they should be in the left rear corner, but anything is possible.

With the power off, push the laser head to the middle of the platform.

When you turn the power on, which way does the head move?

In particular, does it move toward the home switches?

I am new enough that i am not enirly sure if it has homing switches but i assume not. When i power on the machine the laser head remains as it is and that point becomes the new home.
I have included some pictures of the rear back corner.


Those green doodads look like they ought to be proximity switches, so they are likely the home switches.

If I have the orientation right, one is on the left side of the cabinet and the other is at the rear of the gantry.

Which means the laser head should move leftward & rearward when you turn the machine on …

… but, because it doesn’t, something else is kaflooie.

The controller display says “Cloudray”, but the collection of machine settings looks very much like a Ruida controller, which suggests they’ve done some extensive modifications to the basic functions.

We recently had a horrendously long & convoluted thread concerning a Ruida controller that did not home, despite everything being set up correctly:

The bottom line seemed to be that something deep inside the controller overrides its visible Enable Homing switches. You should read through that thread and try some of the tests, but I have the uneasy feeling everything is fine except for the controller’s behavior.

If that’s the case for your machine, then the only way to “home” it will be to follow the manual homing process generally used for tabletop diode lasers: