Offset Problem: ALARM:2 G-code motion target exceeds machine travel

I’m pretty new to laser engraving and got a Problem in lightburn.
My Aufero Laser 1 works fine in LaserGRBL but in lightburn it seems to have an offset problem (had it from the first day on).
The laser is homing correctly and I can move it to all four corners using the arrow buttons in the move panel.
But when I try to frame/cut/engrave a form that is closer than 30mm to x0 and/or 20mm to y0 I receive the following error:

G-code motion target exceeds machine travel.

What I also found out, is that moving the laser to a certain position in the move window (insert the numbers and hit Go) has the same problem: I can not move to positions below x30y20 and when i move to x30y20 the laser actually moves to the home position.

Please help! I’d like to use the full area which I can’t at the moment.

I am really sorry. I found this post before and I was sure I checked the values from $# and they were all 0.
But checking again I actually found this:


So the solution from G-code motion target exceeds machine travel HELP - #7 by OrturTech also worked for me.
Just type $RST=* into the console and hit enter. Restart the laser and works like a charm now.

Do make sure you running latest firmware though to avoid the offsets again

Gil, can you provide some insight into what it is in the firmware that’s creating these offset scenarios? This seems really commonplace.

Hello, I have the same problem. Sometimes it burns an sometimes it stopped with the same error.


Das G-Code-Bewegungsziel überschreitet den Maschinenweg. Die Maschinenposition sicher beibehalten. Der Alarm kann entsperrt werden. (Klicken Sie mit der rechten Maustaste auf die Schaltfläche „Geräte“, um die Verbindung zurückzusetzen.)

And I don´t know what can I do, because i cannot say which time it runs or which time the error comes by burning.

Did you try the fix described in this Topic?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.