One Axis of Ortur Laser master 2 S2 not moving

Hi All,

Need some assistance with my Ortur Laser Master 2 S2. I have been using it for quite some time but recently it has developed a snag wherein one of the axis doesn’t home. While the Y axis homes, the X axis doesn’t move. When pressing start button, there is only movement in Y axis however there is a buzzing sound coming from X axis motors for few seconds but there is no movement.

I tried contacting Ortur customer and they suggested few things (Check the Emergency switch is always on triggered mode, Inspect Motherboard pins, Unplug Laser cable and the X cable from the motor, Bring them back. Unplug Y cable, and plug X cable on Y motor. Switch on machine. Check if Y moves driven by X)

I tried all the things. When I am interchanging the X axis and Y axis motor cable there is no movement in either of the axis and there is a slight buzz coming from one of the motors. I have checked the tension of the belt and it’s fine.

Would highly appreciate if anyone has a solution to this problem Thank you. J

The most common event that causes an axis to not move is a loose set screw or grub screw in a pulley. With a small Allen Wrench or hex key confirm that all the screws in the pulleys and couplers are tight by attempting to tighten them.

Once the fasteners are tight - Slowly move the laser head by hand to verify that the drive mechanisms are free running and that they will turn the motors and that you can feel the notchy motor resistance a little bit.

The order of the motor and cable swapping is important. We should revisit that after the set screws and drive mechanisms have been checked.

1 Like

I tried tightening the screws but no luck. I pulled out the X axis motor cable and inserted the Y axis motor. However, there was no movement after that. But there was a slight buzz coming from the motor as before. Do you think there is a fault in the cable or motherboard?

This is half of the troubleshooting step - I’d like to confirm that you switched the cables at the motor end and not the motherboard end so far. :slight_smile:

We also need to know if the Y axis motor cable can be plugged into the x-axis motor and produce movement. (if it will reach)

It would be wise to slowly move the laser engraver head to the middle of the work area by hand to confirm that the device is not physically stuck.

It’s easy to get these troubleshooting steps crossed up when typing.

Initial condition: x-axis symptom
Y axis: Motor ok, Cable ok, driver chip on motherboard ok
X axis: Motor unknown, Cable unknown, Driver on motherboard unknown

Step 1. swap cables at motor end.

Outcome 1.
If (and only if) symptom now presents on Y axis and not X axis then the problem could be the cable that moved to the Y axis or the X axis driver on the other end of that cable in the motherboard.

Outcome 2.
If (and only if) the symptom did not change place - the x axis motor alone is bad or the x axis is physically stuck.

Outcome 3.
If (and only if) the x axis motor behaviour is unchanged and a new symptom emerges on the Y axis. The x axis motor is bad (or stuck) and a the cable or board may have been the cause or result.

Outcome 4.
Both motors suddenly start working as anticipated. An intermittent component is present or an error was generated previously.

Please let me know which outcome you have, and then we’ll attempt the next test. :slight_smile:

Thank you, John for such a detailed reply. I did swipe the cable at the motor end and tried. After doing so, I experienced things which you outlined in outcome 1. There was movement only in the X axis, whereas the Y axis didn’t move.
Where does the problem lie? Do you think motherboard is faulty or there is a fault in cable?

Great, We have demonstrated that both motors are good.

The follow up troubleshooting step for Outcome 1 is to swap the x-axis and y-axis motor control cables at the motherboard end - noting that the cables are still swapped at the motor end.

With the motor control cables swapped at the motherboard:

a) If the original symptoms appear then it is not the cable - it’s the board.

b) If the Y axis does not move, it is the cable currently on the Y axis that shows a problem.

c) If everything starts working you found and cured a poor connection at the motherboard.

Hi John,
I had raised an issue with Ortur regarding the same and they had sent me a new motherboard. It’s working fine with the new motherboard. Thank you so much for all the support and patience.

1 Like

My pleasure, I’m glad it’s sorted.

I’m also glad the process is available to help other folks with a similar looking problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.