Ortur Connection issues

I’ve looked through many topics and can’t find a answer to my problem. I have a Ortur Laser Master 2 and just got it put together. I downloaded 32G lightburn and attempted to connect it. With the automatic search for device it wouldn’t recognize my machine so I tried doing it manually. I went through GRBL, then Serial/USB, named the device and put in the dimensions, put in the front left as the home, and then it says it’s finished. When I go to lightburn controls machine still doesn’t show up and controls of course won’t move anything. It’s got power, all connections seemed tight, and USB is plugged in. Can some one give me some help. Thanks in advance…

Have you installed the drivers for the Ortur?

One place to get them:
https://www.facebook.com/groups/orturusergroup/permalink/995004457579655

I am having the same problem. I am using a MacBook Air and my laser stays disconnected. I tried both USB ports, restarted computer, tried an external hard drive to ensure the USB port works. I cannot figure out how to show that it is connected.

Have you selected the USB port that the laser is connected to? (Do you have the option to do so?) Click here where it says “Choose”:

image

Hi, i just bought my ortur laser master 2 engraver. I installed everything that needs to be installed, GRBL software and the drivers as stated on the manual for Ortur LM2. My computer is windows 10 62bit. The computer cannot connect to GRBL software and even to Lightburn which I installed too. It is flagging “waiting for connection” at Lightburn software. Please note that I already changed the usb cable because it might be the problem. The port I chose already too which is COM.6 Please help how to proceed.

This would indicate there might be a hardware or wiring issue. I suggest you reach out to the nice folks at Ortur Support for further assistance.