Ortur Laser Maser 2 pro won't start when I press start on lightburn

Good day person who is reading this,

My Machine won’t start when I press the start button on lightburn, it’ll just do nothing and say “busy” while counting on the progress bar.

It will jog, home, frame, and even fire the laser when prompted but it will 100% of the time just do nothing and say busy when i press start.

My machine was working fine before but it had some hardware issues as a pin popped and i got a new motherboard via the warranty. Now I’m faced with this new issue i don’t know how to overcome.

Here is a screen shot of when i press start

Here is one when i press stop

Thank you for you time.

Push “Save Gcode” in Laser window for that design and save with .txt extension. Then upload here. Want to make sure there’s nothing wrong with the g-code.

Also, can you take a screenshot of Edit->Device Settings and post here?

Hello Berainlb,

Thank you for your help, here is what you’ve requested
Bernard Gift from gabby inittials.txt (125.9 KB)

You have created a device using the “GRBL-LPC” device type. For your laser it really should be “GRBL”.

Push “Devices” button in Laser window. Click on your device, then Edit. Change to “GRBL”. Then continue through Next until you complete the setup.

Test again.

I have done the changed to no avail unfortunately.
It does switch a bit before giving up sometimes this run though

Does your machine have an emergency stop switch? If so, can you make sure it’s not engaged?

After looking more closely at the status report it seems a “Hold” pin is being detected. I’ve never seen that before and it may be related to what’s going on.

Can you generate new gcode? Let’s make sure there’s nothing there to look at.

Indeed it does have an emergency stop switch, i’ve engaged it and disengaged it a few time to see it was working and it seams to be okay as in letting the machine frame when it’s not engaged and vise versa.

Here is the new gcode you’ve requested.
Bernard Gift from gabby inittials 2nd test.txt (167.3 KB)

Gcode now looks fine as far as I can tell.

Can you try engaging the emergency stop switch and then running this in Console a few times? Then try the same thing with it disengaged.


Return Console output please.

Not sure what else might be going on. You may want to revisit the wiring of the board to make sure everything is in the correct position and that nothing is getting shorted or jumpered when it shouldn’t be.

Here is the console after doing as instrusted.

I’ve also opened up the motherboard box then unplugged and replugged everything to make sure nothing was lose or plugged in the wrong place. Also did that with all external connectors to no vail.
the firmware seems to up to date as well on the motherboard so I’m pretty stumped.

Not sure what else could be going on. I do think the H pin being on may be related to the issue but not certain.

Let’s see if @OrturTech has any guidance on this.

We need to go back to bare basics

Without usb → just power @GVictor
machine from center, does it home correctly?

1 Like

Hello Gil,

Thank you for your help.
Indeed the machine is able to home from the center point, I even made it home from the opposite corner just to make sure.

if this is the case in console type
press enter
press enter

then post output please
also try a simple box in he center of the grid, do frame, what comes after in console?

Here is what the console has output when i typed that and after I framed that black box in the center.
The machine was able to frame it with no issue at first but now is stuck in “busy 100%” after i frame it a again.

I’ve found a new detail! I don’t know why I didn’t try this before but it workd fine ONLY when I use “Line”.
If the layer was set to “Fill” or “Offset Fill”, I would encounter the same issue. Same goes for adding in a “Fill” layer after a line layer. But also when the “Line” layer has curves, the machine will just give up. It will happily do a box line but will absolutely refuse to do a circle line.

I hope that detail helps, I’m currently trying to fiddle with the “Fill” settings

2 questions
are those 2 lines crossing the center, set to tool layers
can you show the cuts layers?

Honestly something is very weird on the behaviour, unless you have a massive overscann %

The 2 lines are the “Show work aria center cross” lines that I think have always have been on (can’t remmember as it’s been a while but it has been usefull so I keep it on.

Is this the overscan you’re talking about? I don’t think I’ve ever turned it on.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.