Ortur laser master 2 axis issue

I have an ortur laser master 2. It homes correctly, however , when I try move it to position x0/y0 on the Move tab, or if I try to frame my object that is clearly on my workspace it goes to the top right and I get an error. I am using absolute coordinates. Attached are some screenshots. I have a video showing the behavior, but can’t seem to load it here. I have also tried to update my firmware, but I get an error when I try to copy or move the bin file into my laser device folder (which on my laptop appears as my E: drive). Any help would be much appreciated!

Appreciate the good details and the photos. For future reference, screenshots are preferred over photos for screen information.

Let’s take one issue at a time… For the ALARM:2 it may be that you’ve set the work size of your laser in Device Settings to too large a size.

Your laser should be 400x400 mm. It looks like you’re closer to 400x430 mm. Switch to mm and then go to device settings and change the work size accordingly.

Test and let us know if that resolves that issue.

As for the firmware update it seems l like you may be trying to apply the wrong firmware to your device. Note that the error message in your photo matches this warning from the firmware update instructions PDF:

The Ortur site is a little tricky to navigate. Note that you have an Ortur Laser Master 2 Pro S2 and you need to navigate to your specific laser. Go to this site to download:
Ortur – Firmware Repository – Ortur

If it doesn’t look exactly like this you’re in the wrong spot. Also download the instructions and follow them exactly. You don’t want to brick your laser.

We need some visual guides
You having a very high sock sdnsor trigger
Thats peculiar for a S2 OLM2

Also after that you got an Alarm 9 - homing fail
So something in your wiring is not right
Could you use this image as a guide - you wiring will be different - but to take a few images

Thank you!

I will take pics tomorrow of the wiring and send, thank you so much for your help!

Here are the wiring pics

More wiring

besides some tension issues on Y belts i cant fault anything on your machine
Dont think you would have a way to move laser right/back and power on to see the homing cycle in video?

Don’t believe I can attach a video to this thread, I’ll try to put one up on google drive and send a link

Here’s a link to a video showing the behavior when I move to position x0/y0 on the move tab within lightburn, or when I select frame for an object within my workspace. Btw, light run read the dimensions of the workspace when it found/added the laser 400x430mm, I didn’t change this, but I did change the display option to inches instead of mm.

This is the behaviour of the machine when powering on? that dont seem right
Could i ask you to try again this way
move head to center of machine
Tap reset once
Press power for 5 seconds and record the initial power up?

also machine being a S2 should show 400x390 as frame size

Here is a link to the power on video. I cannot get the head to move anywhere but top right or home - so video shows power on from top right. Also, FYI - I was able to update firmware for my 2 S2 machine (1.87).

It looks like the limit switch for the Y-axis is too far away and is not getting triggered? This is the switch that’s on the front left of the machine.

You can test this by trying to rehome and manually triggering the switch. The laser head should immediately stop moving toward the front of the machine. It will continue going left and stop when it hits the limit switch to the left.

You can manually move the laser head to the middle of the bed before powering on. You don’t want the laser head crashing if you can help it.

If the limit switch test works, remount the switch a little farther forward so it can be triggered. If it cannot, then lift the laser head module so that it’s not impeded by the front rail.

Retest and report back.

Woohoo! That fixed it. Thanks so much ! Would have never figured that out on my own.

Good catch, i am puzzled though because by design it should fit perfectly, trying to figure out how the bracket does not allow the head to click the switch without touching the frame

@AmyB Your Y belts do need some tightening!

Could the machine be out of square?

Also, has the design of the switch mount changed from the Laser Master 2? On the LM2 I have a lot of room to be able to change mounting position by moving the acrylic plate. It’s not keyed to any specific position.

One thing that looked odd to me was the laser module itself was mounted very low. Is that normal for OLM2 Pro S2?

This is a OLM2 S2, not pro.
By definition, the laser should have 3mm gap from shield to rail with the switch in place

So i am trying to see why there isnt room

Got you. Missed that.