Ortur Laser Master 2 Pro Homing fail

Hello to all!
After spending a few hours on troubleshooting i still have the problem that my machine does no homing if i want to do that in Lightburn or without a PC.

The problem came up after i canceled a laserjob. After that it was impossible to home the laser.

When i click the “Home” Button, the X and Y axis makes a step of 3mm in + direction and than it stops. If i click on “Go to origin” it moves to the wrong direction (right behind) although it should move to the front left. I never changed a direction in the settings.
The following message is in the console:
Homing fail. Cycle failed to clear limit switch when pulling off. Try increasing pull-off setting or check wiring.
Ortur Laser Master 2 Pro S2 Ready!
OLF:OLF 187.
[MSG: Warning: Flame Sensor Disabled by User OverRide]
[MSG: Flame detector active,Ambient infrared value:0]
Grbl 1.1f [’$’ for help]
[MSG:’$H’|’$X’ to unlock]
[MSG:Caution: Unlocked]

I have checked all wires and limit switches and they are all ok and the signal comes to the mainboard.

I updated to the newest firmware 187 from ortur.

I loaded the standard grbl settings from ortur.
I reset all settings on motherboard with $RST=*

All axis working well if i do a laser job (without homing before).

I tested homing on another pc with new installed Lightburn software and it worked well. Then i changed the usb cable to my first pc (where i had the problem before) and the problem is still there. Now i know that it must be a software problem but i don´t what what´s the reason therefore.

I don’t know what i can do more.

Hope someone of you have any ideas.

Thank you in advance!

sounds like a stuck or shorted limit switch…

The homing sequence:

Move the head to the limit, back off a certain distance then move back towards the switch at a slower speed for a more accurate detection of the switch.

I would think it would move in the negative direction looking for home, then attempt to back off (move in the positive direction)… I read the error as it thinks it’s hit the switch and is attempting to back off and fails.

That sounds like the switch is stuck or shorted…

If homing fails, the machine is ‘lost’ or thinks where it’s at is 0, 0

Good luck

Re read your statement…

The error message you are getting is from the grbl controller, not lightburn. It shouldn’t make a difference with the same machine and a different computer…

So I don’t feel I’m following you…


This part is confusing to me. Homing is largely a function of the laser, not the PC or LightBurn. LightBurn can simply request the controller to home. Can you get homing to work reliably with the other computer?

If you have no computer connected at all and you turn on the laser, does it home properly? If not, can you describe what it does?

Hi Jack,
thank you for your answer and your time!
I´ve tested both limit switches and they work correctly and the signals are getting through the wires to the mainboard.
I´ve tested it with the Freeware LaserGRBL, too and the problem is the the same: It does no homing. Only a step of 3mm in both directions X+ and Y± (I think it is the way from value $27 Homing pull off).

1 Like

Thank you for your answer.
I´ve run another test on a third pc with new installed Lightburn and the problem of no homing ist still there.
Here is the description of what it does after turning on the machine:
Case 1 (USB-Cable is unplugged):
No reaction of both axes → the red led is flashing.

Case 2 (USB cable is connected to PC and Lightburn is closed):
No reaction of both axes → the red led is flashing and the blue led is on.

Case 3 (USB cable is connected to PC and Lightburn is sarted):
If i go to “devices” in lightburn and i choose “COM3” for USB-Port the laser makes a step of 3mm in both axes (Y+ and X+) and then stops. The red and the blue led are now on constantly but laser laser is not homed. If i click on “HOME” it only makes the little steps (3mm) and then i get the message:
Homing fail. Cycle failed to clear limit switch when pulling off. Try increasing pull-off setting or check wiring.”
It´s really confusing me andI´m very frustraded. Could it maybe be a fault of the motherboard?
Thank you all for your help!

This actually makes me feel better about it as the symptoms otherwise didn’t make sense. It seems that the issue is somewhat inconsistent then, meaning that homing can work occasionally or under the right circumstances.

I think these tests are very telling. Somehow the laser isn’t attempting to home on startup. Have tried hitting the reset button on the laser? If not, perhaps try hitting reset, then power cycle. Does the behavior change?

Where is the laser head when you turn on the laser? If not already, can you move the laser head to the middle of the frame?

When you say there’s no reaction is there no sound or movement at all when you start the machine?

What was your procedure for testing this?

Can you try one thing? With no computer connected, power on laser. Then manually trigger both switches. Does anything happen? Trigger 2nd time. Any change?

Try the same thing with PC connected and LightBurn on.

How long does this process take? Does it take some time to timeout before you get the ALARM:8?

The error almost makes it seem like it’s in the middle of a homing cycle currently. Pull-off would only occur after the 2nd successful connection with limit switch.

This is why I’ve asked for your limit switch testing procedure. I’m wondering if the limit switches are sending a bad signal or indicating constant trigger state.

Another test: disconnect limit switches and power cycle. Be ready to pull power so you don’t crash the head. Any change in behavior?

Possible but the fact that it worked earlier and the fact that it worked once when you connected to other PC makes me think something else is going on.

First step in troubling is to read the error message and correct what the machine is complaining about.

IMHO, it thinks it’s on the switches when you initiate a home or power up. The attempt to back off fails. That’s it’s complaint and the correct place to start a diagnosis.

It is detecting no transition to ‘inactive’ when it attempts to back off.

The proper diagnosis is switches → wire → controller. If switches → wire is OK that leaves the controller.

@berainlb suggestion of power it on without the limits connected is great. However from pictures I’ve seen, it doesn’t appear that it’s an option since it’s single connector.?

If @Blaschi information is correct, that the switches and wiring is in good shape that pretty much would indicate a hardware problem at the controller end.

@Blaschi could elaborate on how you ‘know’ these are OK. Ohm’d them out, psychic? I’d have more confidence.

I’d at least pull the connector and visually ensure there is nothing ‘shorting’ the limits in some way.

Good luck


If it can’t be disconnected at the controller then could be disconnected at the switch.

I’m inclined to agree. If problems persist with limit switches disconnected then very likely hardware and mostly likely on the controller.

That leaves the wiring/connector as ‘questionable’. Low probability, but I’ve been burnt before with a shorted wiring harness or connector.

Maybe you know of a way to get grbl to display the state of the limit switches. It would be interesting to see if once it errors out, if it detects those as being active. I saw this somewhere, but don’t remember where or what command sequence displays these values.


Agreed. There’s still value in isolating issues with the switch vs cable.

Issuing ? for status report may show limit switch state status with certain compiles of GRBL. This may also depend on mask value provided in $10.

Pn:P followed by X and/or Y indicate switch activation.

Yes, I tried it very often. It makes no change. If I turn power on it really does nothing. Only the red LED is flashing.

Did you check the limit switch status with the commands @berainlb suggested?

If it says it’s ‘active’, you have to find out why.


Here I have some pictures and videos because I think it says more than words:

I also tested the signal of the limit switches on the plug from motherboard and it was there.
I really think that it’s a failure of my motherboard.

Watched the video. Looks like the same issue to me. It thinks it’s on the limit switches.

Everything looks good, including the limit switches. I’d have taken your word for an ohmmeter…

I think you’ve chased it down as far as you can without removing the controller and checking for some type of debris shorting things out.

How new is this machine?


Lots of good photos and videos there. Thanks for documenting so well.

Can you run ? in Console and check the status of “Pn”? Would like to confirm that they don’t show as being triggered.

Just for due diligence can you run these commands in Console and return results?


Might want to post the syntax of the ‘Pn’. My grbl chokes on it and a bunch of variations. I don’t seem to see it when I search…



It’s from November last year but I used it not often (maybe 20 hours total). Now i built an enclosure and could start and now I have this f…ing problem :frowning:

“Pn” is the output. You use standard ? to show status report which includes the Pn.

I’ll do these tests tomorrow because now it’s late and i have to work tomorrow.
Thank you all for your support!

Probably why I had difficulties… Thanks…

My grbl isn’t cooperating… $10 was 0

Grbl 1.1f [’$’ for help]
[MSG:’$H’|’$X’ to unlock]
[MSG:Caution: Unlocked]

1.1f is that an issue?

It would be nice to be able to drive this… :frowning: