Ortur Laser Master 2 Pro not connecting to Lightburn

Hi I got my Ortur Laser a few months ago and it worked fine. I set it down for a few months untouched and just turned it on again and updated Lightburn to newest and usually it moves right away but it didn’t and I tried updating the firmware and changing the cable and it never shows up on find my devices or through manual setup just says. “waiting for connection”. Really disappointed I need this to work rn. How can I. get this. to connect again. I see there are new s2 version mine is the Laser Master 2 pro and I am on macbook

And my laser moves fine when i hit the power button from the device itself so it is moving fine just some software connection issue. And so obviously and commands like move or fire do nothing from computer cause can’t connect

I unistalled new version and put back to old version 9.24 and seems connected so probably works thank jesus

1 Like

I just downloaded the new version and the same thing is happening to me

Can you make sure that the correct port has been selected in the Laser window?


1 Like

I don’t feel like dealing with it so just going to keep it on 9.24 for at lease a month prob then may try again

I just purchased an Ortur Laser Master 2 Pro S2 and experienced this problem on OSX Monterey with a new install. After removing LightBurn V1.0.06 and installing the older version V0.9.24, it connected immediately.

I’m happy to help further diagnose this problem if needed. For example I connected to the USB serial port with a serial terminal and was able to execute GRBL commands directly – allowing me to determine that the machine is working as expected.

I’m not aware of anything in the newer versions that would affect connections but 2 incidences seem odd.

@LightBurn Could there be something more to this?

1 Like

I have the same issue. Ran fine on both the previous versions. But does not run on this one. 1.0.06

Can you confirm that going back to the old version fixes the issue?

My issue is similare but not exact. I hope I am doing ther right thing by tagging it here rather than starting a new thread. I am using 1.0.06 with my Ortur Laser Master 2 Pro. Every time my laser shuts off (after enough time of disuse) or I shut it off, I have to restart Lightburn and re-setup my device. It sets it up on COM3, and everything works. But if I shut down, disconnect the cord or anything that breaks the connection, COM3 is no longer an option for me in the dropdown and I need to remove the device and re-discover it. Has anyone else seen this or am I doing something incorrectly?

This is likely different. Right click on Devices to force a reconnect. If that solves it this is different issue.