Ortur Laser Master 2 Pro using Lightburn

The laser stops at about 36% of the job. Error 4089. I’ve tried it three times and the same thing happens. Grateful for any help

Who’s giving you that error?

Can you post your .lbrn2 file here?
Just drop it on the editing window. :smiley_cat:

I changed the job location from “job location” to “absolute position”. The job burned correctly but 13" to the right of the home position (where I had the image set) which is set at lower left corner.

Sorry, but you’ll have to remind me, does your machine home on power up, or do you have to set it manually?

Did you go through the Common Grbl setups?

If possible post the .lbrn2 file and a screenshot of the ‘Device settings’ (Edit → Device settings) along with a screenshot of the whole screen with the laser window enabled.

:slight_smile:

It homes automatically at start up.
A&R_Boards_48.666x56.675_backup.lbrn2 (80.3 KB)


Thank you

That looks OK assuming it homes at the front left.

What is your $13 register set to?
Sets position feedback units from mm to inches. $13=1 for inches or $13=0 for mm

Can you do a screen shot of the ‘edit → machine settings?’

:slight_smile:

Check your machine settings for Home position. An Ortur LM should home to the Max Y, Min X position (Upper Left). That you get a Homing error message on startup hints that the machine settings are incorrect.
While you’re setting up, turn off auto home on startup to keep from getting errors.

So in reality, home is left rear? Should be able to tell lightburn that and not have to fiddle with stuff.?

I ‘assume’ lightburn thinks ‘home’ is min x, min y…???

I think I’d try telling Lightburn that home is rear left, not much to loose. It seems that grbl would report it’s position…?

Where/what/who gave him the “Error 4089” message?

:slight_smile:

Ya know, if you want to help, it would help OP if you actually knew how this platform worked. HOME is Max Y, Min X, ORIGIN is 0,0. HOME and HOMING DIRECTION is set in the machine settings for a GRBL platform.

You seem to have an offset in your EEPROM

Maybe if you type ## in console you might notice you have G95 other than 0x0x0

Try this
In console where it says (Type gcode here)
Input $RST=*
Press enter
Confirm it worked if you get a [MSG: Restoring defaults]
Power cycle your ortur (Off → On)
Try again in absolute coordenates

1 Like

it worked perfectly. I can’t tell you how much I appreciate this!

2 Likes