Ortur Laser Pro 2 Framing Problems

  1. Ortur Laser Master 2

  2. GRBL

I have uninstalled and tried all versions 1-4 and I get the same results.

I could not find any forum that specifically detailed my issue and after dealing with my particular problem I am tired of dealing with such a simple problem that I has been 2 days now. So I created my own hoping that someone has had this same and been able to figure it out.

I etch 4" and 6" white tile, painted white and then I burn them with images. They measure 105.175 mm perimeter and then the image is usually about 102 mm or 4 inches so I need very precise measurements to line my images up. I use the framing tool set on Current Position, Lower Row Centered to box in my tile and center my project on every project. I have been doing this ever since I got my Ortur.

I did run into some problems that the staff helped me with and I use the same steps every time, but as of a couple of days ago there was an update and I am no longer able to use the framing tool. After several hours of trial and error I decided to uninstall it and install a version 3, it doesn’t work either, then I installed version 2, it doesn’t allow me to frame either.

Steps.

  1. Create square /layer

  2. Place it on the board accordingly

  3. Home Module

  4. Get Position

  5. Click set laser position or Tear Drop Icon

  6. Job Origin is set on Current Position

  7. Click on Green Square

  8. Click on Fire Button

  9. Physically line up Tile

  10. Click Frame Button

  11. Watch laser and adjust tile accordingly.

  12. Click fire button to visually line up

  13. Click frame and it moves to the left by just a few mm rendering the last adjustment void. So it never lines up.

This is where the framing problem occurs and I even started marking the middle line of the tile (center). It creates the frame, but after I physically move the tile to adjust for where it is off, the laser moves to the left by mm, meaning it jogs after each framing (it doesn’t jump teeth, it just adjusts somehow and moves on it’s own). So after I align my tile it doesn’t matter because it continually moves to the left and continues until I eventually run into the left rail if I kept going (mm by mm). The belts are tight, nothing is jumping, grinding, etc.

It did not start until I updated and even after I uninstalled and reinstalled a later version, it still does it.

Thank You

You can try to go back to the last known working version you used. Click on this older version (← click) link. Please let us know your results and we can go from there. :slight_smile:

1 Like

I tried version 1 today and got the same results. But I also tried LaserGRBL and it worked just fine. So, there is no way I am going to use that program but at least I know it is not the Ortur and it is not me. There is something wrong somewhere, I literally made no changes, I do the same thing on every project except change the power, speed, etc. But after I updated to 4 it is almost like I have this internal bug that has corrupted my system and even after removing the program and performing a clean reinstall, it won’t work.

I am sorry for not being more specific as to the version. What version did you last find success? That is the version I’d like you to try again, if you would. :slight_smile:

I was fine with version 3. Then I updated to 4 and for whatever reason even after an uninstall cannot undo whatever it did to my framing bug and I cannot print. The laser will not stay inbounds.

Does your Ortur have limit switches? If yes, ‘Absolute Coordinates’ might be a better option. Coordinates and Job Origin - LightBurn Software Documentation

If not, this is worth review. Common Grbl Setups - LightBurn Software Documentation

@OrturTech, other suggestions?

Could you post a FULL screen shot of your lightburn with the design in place please

Also in console can you type $# and press Enter
Post image or output

I tried that already and versions prior to that as well. For whatever reason, all versions now “the framing tool” now malfunctions and the images will not stay in alignment.

Thanks for that suggestion. I tried that “Absolute Coordinates” don’t prefer it but can deal with it and it does the same thing.


I cant see from yuour description and your process an software/work flow process error

So it must be mechanical, i am thinking belts, sprockets or something that is making you lose a few mm. The fact is just a few mm matters.
May i ask
can you replicate this image + Belts please
As close as mimic image as possible

I also included screenshots of a Master Restore Code that is supposed to reset my Ortur but instead locks it up. I have to reset it, I also included two other screen shots of coding I was asked to try. Nothing has worked.


Home Limit Switch


Lined Up


Offset to the Left

Everything looks spot on
Try unplugging the offline controller so the chatter clears
Then for the sake of step by stepping
Try a smaller square, on cardboard say. but in absolute coordenates. Home. Print once. Home again , print once
Or if you prefer this test file just repeat it over and over IN absolute coordenates
Dot Test with Angle.lbrn (46.3 KB)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.