Ortur LM2 Laser Not Able to Run G-Code

I’ve had my laser (Ortur LM2) for nearly a year and after the initial setup hiccups, it has worked find for me for what I am doing. I don’t use it all that often and when I set out on my latest project for my wife a few days ago I updated Lightburn to 1.0.0 which worked fine until today. over the past week, I probably sent the laser g-code 100+ times without any issue. Even today I burned several things before my issue.

I was making a series of test cuts to narrow down the cut times by adjusting the size of the text and the interval. When I went to make the next burn, maybe the 10th of the night, the laser did nothing. At the progress bar, it says “Busy” but the progress bar runs through. The g-code also appears to run through when I enable “view all” in the console. The laser will run from the move window and will go through its homing process without issue even when manually moved to the middle of the cutting area. It will not fire from the move window. I have the same issue using the GRBL software that comes with it.

Things I have tried:

  • Resting the laser several times
  • Resetting Lightburn several times
  • Loading a new Lightburn file
  • Trying a saved Lightburn file I successfully cut
  • Switching USB ports
  • Running GRBL basic software
  • Updating the Ortur firmare

I am at a lost and cannot find anywhere where someone had a similar issue. Any help is appreciated and please let me know what additional information is needed. While I wait I am going to try another computer.

Are you saying you cannot get the laser to fire at all? No beam is produced?

You may want to reach out to the nice folks at Ortur Support and open a ticket. You may have a hardware failure, indicated by not having a beam produced (“It will not fire from the move window.”) by two different pieces of software.

Maybe @OrturTech might have a troubleshooting process to assist.

Thank you Rick,

That’s exactly what’s going on. No laser fire at all. I just submitted a ticket just now after using my other computer failed to fix it. Not that I thought it would, but it was the last option available to me.

I really do hope @OrturTech can help me out.

1.4am for me atm, but i will read and seee if theres anything i can help with instantly


Questions if i can
a) On POWER only, no usb
Moving head to center and pressing power button for 5 seconds
1- Do you see power adapter green SoLID LED?
2- Do you get homing cycle?
b) if yes to above, when you plug your usb cable does computer respond with a shime?
If so can you check device manager, ports section. What com port is given to ortur
(Unplug and plug usb cable a fre times for confirmation)

Yes, when I power the laser on when unconnected it lights up solid and goes through the homing cycle.

It does chime and it is assigned COM3

Any chance you can send a screen shot of device managers with expanded PORTS section on connected machine please?
At the same time, full screen shot of lightburn showing laser pannel + Console?

Try restoring defaults on your controller
ALl seems correct so far

Did that with no change. I tried running a cut with the same result after resetting.

lets confirm some wiring. could you replicate the iamge on your machine?
Specially the 2 plugs above the Y stepper. unplug and verify any damage
Also when trying to cut To clarify
Motion = ok
Laser head. Do you get FAN on, Red LED on, Blue LED on?

I removed, inspected, and replaced the connectors. They were all clean, the wires were snug in the plastic connectors, and the pins were unbent.

When I hit play on the cut I get a flashing orange/yellow light next to the “PWN” on the chip seen in the photo. In Lightburn it shows what was shown in the last image of Lightburn. I now see a solid red light and a flashing blue light behind the reset button. It may have been doing that the whole time but I didn’t look for it. I do not get the fan to initiate.

Rest of wiring images please?

Cant be certain but Does the laser cable is fully engaged?

Also to clarify On top of the laser you get nothing?
No fan, no LEDs what so ever?
Here you get 12v light up?

It is fully engaged and none of the wires appear to be loose. There are no LED’s on top that come on and the fan does not switch on.

The 12V light does not turn on either.

Then what is happening is somewhere between the motherboard TOP connector and the pinboard (little board with LEDS) bottom connector the Ground or the 12v is being lost
Possibly a microfracuture on the cable?
Do you own a multimeter? If so what you could easily do is test continuity
As such

What we want to know is from the output of the motherboard to the pinboard you have continuity on each cable.
We know the 12v or ground arent reaching the pinboard otherwise the 12v would light up
So options are
a) wire cut in between motherboars ->>>> pinboard
b) Motherboad faulty

However normally if the motherboard had became faulty you wouldnt have 12v overall → therefore no motion

So with a multimeer you could just unplug both cables (all 4) and make sure with the images above as guide you are getting continuity between each cable

I just checked all the wires several times with consistent results showing that there is continuity along them all. I also checked the board with the three lights and I can get continuity and both the PWN and 12V LEDs to light up. There is also continuity from the power supply to the first connection.

Can you then set the laser in Focus mode, or, make a box, unplug both steppers cable. 1% power, and start (unplugging the steppers would let you test without the head going all ovr the palce) fire button would be ideal.
Can you measure what you get, on a 20V DC on your meter
Between BLACK + red
Between Black + White
IF you get 12v between black and white when trying to engrave
and about 0.3V (at 1% pwoer) on black and white
Then the module is dead compleatly. WHich honestly sounds unusual

I get 0.2V between Black and white and 12V between Black and red at 1% power during engraving.